HDU 3123(ZZULI 1605) GCC(递推)  …

GCC

Time Limit:1000MS  Memory Limit:65536K
Total Submit:42 Accepted:12

Description

The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m

Input

The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

Output

Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!) % m.
Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

Sample Input

1
10 861017

Sample Output

593846

Source

 

这题由于原来做过这类的题,所以很短时间就水过了(不过代码有点儿小漏洞,在杭电上提交需要稍微修改一下)

 

题意很简单,就是求(0! + 1! + 2! + 3! + 4! + ... + n!) % m的值

 

这题我用到了一个递推方程,假如说(n-1)!%m为k的话,那么n!%m=(k*n)%m,因为(a%m +b%m )%m= (a+b)%m

 

这样的话题就很简单了,不过要注意两点:1、0 1这组数据是个特例,所以在最后输出的时候要特殊处理或者结果再对m取余一下,2、递推用到的num和sum要定义为__int64类型的,不然不能过。

 

 

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
      int m , T , i ,ss;
      char n [ 111 ];
      __int64 sum , num;
      scanf( "%d" , & T);
      while( T --)
      {
              scanf( "%s%d" , &n , & m);
              if( strlen(n) < 10)ss = atoi(n);
              else ss = m;
              if(ss > m)ss = m;
              num = 1; sum = 1;
              for( i = 1; i <=ss; i ++)
              {
                      num =( num * i) % m;
                      sum =( sum + num) % m;
              }
              printf( "%I64d \n " , sum % m);
      }
      return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值