hdu1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44334    Accepted Submission(s): 19653


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2



大致题意:输入n,用这n个数形成一个环  使得相邻的数之和为素数。

思路:用于n<20 所以用朴素法求出39以内的素数并用v数组标记,由于使用字典序输出答案,只需要按照从1到n的顺序寻找所得的自然是字典序。

dfs主体:从1开始dfs 判断每个数字,找不到答案时回溯。即得出答案。

package 搜索2;
import java.util.*;
public class Main 
{
	public static void main(String args[])
	{
		boolean[] v=new boolean[40];
		Scanner s=new Scanner(System.in);
		for (int i=1;i<=39;i++) v[i]=true;
		v[1]=false;
		boolean flag=false;
		for (int i=4;i<=39;i++)
		{
			for (int j=2;j<=i-1;j++)
			{
				if (i%j==0) 
					{
						v[i]=false;break;
					}
			}		
		}
		int total=0;
		while (s.hasNext())
		{
			total+=1;
			int n=s.nextInt();
			flag=false;
			slove kk=new slove(v,n,total,flag);
			kk.dfs(1,1);
			System.out.println();
		}
	}
}

class slove
{
	boolean[] v=new boolean[40];
	int[] ans=new int[30];
	int n=0;
	int total;
	boolean flag;
	boolean[] vis=new boolean[50];
	public slove(boolean[] v,int n,int total,boolean flag)
	{
		this.v=v;
		this.ans=ans;
		this.n=n;
		for (int i=2;i<=49;i++) vis[i]=false;
		vis[1]=true;
		this.total=total;
		this.flag=flag;
	}
	void dfs(int x,int tot)
	{
		vis[x]=true;
		if (tot<n)
		{
			for (int i=1;i<=n;i++)
			{
				if ((v[x+i])&&(i!=x)&&(!vis[i])) 
				{
					tot=tot+1;
					ans[tot]=i;
					dfs(i,tot);
					ans[tot]=0;
					tot=tot-1;
					vis[i]=false;
				}
			}
		}
		if ((tot==n)&&(v[1+ans[n]]))
		{
			if (!flag)
			{
				System.out.println("Case "+total+":");
				flag=true;
			}
			System.out.print(1+" ");
			for (int i=2;i<=n;i++) 
				{
					if (i!=n) System.out.print(ans[i]+" ");
					else System.out.println(ans[i]);
				}
			
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值