SZ斐波拉契数列

Problem Description

Fibonacci sequence is familiar to you, right? Here comes the SZ Fibonacci sequence, with the property like the following formula.
F(n)= a (n=1)
F(n)= b (n=2)
F(n)= F(n-1)+F(n-2), n>2 and n is odd
F(n)= F(n-1)+F(n-2)+F(n-3), n>2 and n is even
Here a and b are constants. Given a,b,and n, your task is to calculate the F(n).

Input

First line of input comes a positive integer T(T<=10), indicating the number of test cases. Each test case contains three positive integer a,b and n(a<=10,b<=10,n<=30)

Output

Print one line containing an integer, i.e.F(n), for each test case.

Sample Input

2
1 2 3
1 3 6

Sample Output

3
24
 
//另一种解法----> 递归
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
	int  f[30]={0},t,n,a,b,i;
   while(scanf("%d",&t)!=EOF)
   {
       while(t--)
	   { memset(f,0,sizeof(f));
	     scanf("%d%d%d",&a,&b,&n);
	     f[1]=a; f[2]=b;
        for(i=3;i<=n;i++)
		{
		   if(i%2!=0)  f[i]=f[i-1]+f[i-2];  //奇数
		   else f[i]=f[i-1]+f[i-2]+f[i-3];	 //偶数
		}
		printf("%d\n",f[n]);
	   }   
   }  
return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值