SZ斐波那契数列

SZ斐波那契数列

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 8
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Fibonacci sequence is familiar to you, right? Here comes the SZ Fibonacci sequence, with the property like following Formula:
F(n) = a (n=1)
F(n) = b (n=2)
F(n) = F(n-1)+F(n-2) (n>2 and n is odd)
F(n) = F(n-1)+F(n-2)+F(n-3) (n>2 and n is even)
here a and b are constants. Given a,b, and n, your task is to calculate the F(n).

Input

Output

print one line containing an integer, i.e.F(n), for each test case.

Sample Input

2
1 2 3
1 3 6

Sample Output

3
24
#include <cstdio>
#include <iostream>
using namespace std;
int main ()
{
    int w[40],a,b,n,t;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&a,&b);
        w[1]=a;
        w[2]=b;
         scanf("%d",&n);
        //cout<<w[1]<<"   "<<w[2]<<endl;
        for (int i=3;i<=40;i++)
        {
            if (i%2==0)
                w[i]=w[i-3]+w[i-2]+w[i-1];
            else
                w[i]=w[i-2]+w[i-1];


        }
 printf("%d\n",w[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值