1049 Counting Ones (30 分)

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:
Each input file contains one test case which gives the positive N (≤2​^30​​ ).

Output Specification:
For each test case, print the number of 1’s in one line.

Sample Input:
12
Sample Output:
5

对于now,有三种情况:
1.now == 0 : 那么 ans += left * a; //因为now==0说明now位只有在left从0left-1的时候会产生1,所以会产生left次,但是又因为右边会重复从0999…出现a次
2.now == 1 : ans += left * a + right + 1;//now = 1的时候就要比上一步多加一个当now为1的时候右边出现0~right个数导致的now为1的次数
3.now >= 2 : ans += (left + 1) * a;//now大于等于2就左边0left的时候会在now位置产生1,所以会产生left次,但是又因为右边会重复从0999…出现a次

//Counting ones
// 如果是出现一的数则用容斥原理能较好的解决
// 这道题是计算一的个数,我们则需要对每一位进行1的累计求解

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
typedef long long ll;
ll n;
ll res=0; //结果 
int main()
{
	scanf("%lld",&n);
	int p = 1;
	int left,right,now; //左边的数,右边的数,当前位的值 
	while(n/p)
	{
		now = (n/p)%10;
		left = n/(p*10);
		right = n%p;
		if(now==0) res += left*p;//0-left-1 左边数的范围 
		else if(now==1) res+=((left*p)+right+1);
		else res+=(left+1)*p;
		p*=10;
	}
	printf("%lld\n",res);
	return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值