Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:2 5 1234567890001 95 1234567890005 100 1234567890003 95 1234567890002 77 1234567890004 85 4 1234567890013 65 1234567890011 25 1234567890014 100 1234567890012 85Sample Output:
9 1234567890005 1 1 1 1234567890014 1 2 1 1234567890001 3 1 2 1234567890003 3 1 2 1234567890004 5 1 4 1234567890012 5 2 2 1234567890002 7 1 5 1234567890013 8 2 3 1234567890011 9 2 4
这道题整体排序问题不大,主要是排名的计算,分为了两个部分,local_rank和final_rank。我采用的是比较复杂的方法,分别进行计算,代码如下,虽然能通过,但是希望以后能想到更好的办法解决。
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
typedef struct info{
char id[14];
int score;
int location_number;
int final_rank;
int local_rank;
}info;
bool cmp(const info &a,const info &b){
if(a.score == b.score){
for(int i = 0;i < 14;i++)
if(a.id[i] != b.id[i])
return a.id[i] < b.id[i];
}
return a.score > b.score;
}
info ss[30005];
int main(void){
int N;
scanf("%d",&N);
int flag = 0;
for(int i = 1;i <= N;i++){
int K;
info s[301];
scanf("%d",&K);
for(int j = 0;j < K;j++){
scanf("%s %d",s[j].id,&s[j].score);
s[j].location_number = i;
}
sort(s,s+K,cmp);
for(int j = 0;j < K;j++){
strcpy(ss[flag].id,s[j].id);
ss[flag].score = s[j].score;
ss[flag].location_number = s[j].location_number;
if(j == 0)
ss[flag].local_rank = 1;
else if(s[j].score != s[j-1].score)
ss[flag].local_rank = j + 1;
else
ss[flag].local_rank = ss[flag - 1].local_rank;
flag++;
}
}
sort(ss,ss+flag,cmp);
printf("%d\n",flag);
for(int i = 0;i < flag;i++){
if(i == 0)
ss[i].final_rank = 1;
else if(ss[i].score != ss[i - 1].score)
ss[i].final_rank = i + 1;
else
ss[i].final_rank = ss[i - 1].final_rank;
printf("%s %d %d %d\n",ss[i].id,ss[i].final_rank,ss[i].location_number,ss[i].local_rank);
}
return 0;
}