PAT A 1001 A+B Format

原题地址:PAT A 1001 A+B Format
题目描述:

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where − 10 ​ 6 ≤ a , b ≤ 10 ​ 6 -{10}^{​6}≤{a,b}≤{10}^{​6} 106a,b106
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991
可能是太久没写代码了,面对一道打卡题卡了有一段时间。
受到知乎内容的启发。
做题历程:考虑对其作为字符串来处理。
如果是负数,它的高位是负号,长度会多一,这样的话可以不管这个数是多少,直接三位三位地添加“,”即可。
这个题目比较考验逻辑。如果真的傻乎乎按照范围去处理的话,很容易漏掉情况。如果范围扩大,可以写一个循环根据长度来判断在何处添加“,”。
感悟:在做题的时候通常时间有限,要用有限的脑力去处理有限的逻辑。
代码如下:

a,b = map(int,input().split())
sum = a+b
sum = str(sum)
result = sum
if eval(sum) > 0:
    if len(sum) > 3:
        result = result[:-3]+','+result[-3:]
        pass
        if len(sum) > 6:
            result = result[:-7]+','+result[-7:]
            pass
else:
    if len(sum) > 4:
        result = result[:-3]+','+result[-3:]
        pass
        if len(sum) > 7:
            result = result[:-7]+','+result[-7:]
            pass
print(result)
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值