An error has occurred on Android Device Monitor

第一次在mac本上使用Android Device Monitor的时候报的错误

图1

图2

其实问题就是这样的:

然而却报了如下的错误:

图3.png

继续找解决方案
Android Device Monitor will not launch, either from Android Studio or from Terminal — UnsupportedClassVersionError
https://stackoverflow.com/questions/42661578/android-device-monitor-will-not-launch-either-from-android-studio-or-from-termi?noredirect=1&lq=1

其实最终发现只需要安装最新的jdk1.8即可。

苹果系统已经包含完整的J2SE,其中就有JDK和JVM(苹果叫VM)。当然如果要升级JDK,那当然要自己下载安装了。 在MAC系统中,jdk的安装路径与windows不同,默认目录是:/System/Libray/Frameworks/JavaVM.Framwork/。
在这个目录下有个Versions目录,里面有不同版本的jdk。

Mac系统自带的jdk路径

用户安装的jdk路径

当然如果还有在Mac系统下切换jdk的需求可以参考
http://www.jianshu.com/p/91bbb537fd52

只是做一个简单的记录!

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/s003603u/article/details/73724698
个人分类: Android工具
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭