hdu1016 Prime Ring Problem

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.
这里写图片描述

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

思路
dfs,但要注意剪枝,不然会TLE.
剪枝部分

if(step>2 && !isprime(a[step-1]+a[step-2]))
        return;
/*************************************************************************
    > File Name: hdu1016.cpp
    > Author:gens_ukiy 
    > Mail: 
    > Created Time: 2016年11月30日 星期三 17时40分56秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<set>
#include<list>
#include<map>
using namespace std;
#define rep(i,a,b) for(int i=(a);i<=(b);(i++))
#define inf 0x3f3f3f
#define ll long long

#define maxn 22
int book[maxn],a[maxn];
int n;
bool isprime(int n){
    rep(i,2,n-1)
        if(n%i==0)
            return false;
    return true;
}


void dfs(int step){
    if(step>2 && !isprime(a[step-1]+a[step-2]))
        return;

    if(step==n+1){
        if(isprime(a[n]+a[1])){
            printf("1 ");
            rep(i,2,n-1)
                printf("%d ",a[i]);
            printf("%d\n",a[n]);
        }
    }

    rep(i,2,n){
        if(!book[i]){
            book[i]=1;
            a[step]=i;
            dfs(step+1);
            book[i]=0;
        }
    }
}
int main()
{
    a[1]=1;
    int cas=1;
    while(cin>>n)
    {
        printf("Case %d:\n",cas++);
        dfs(2); 
        printf("\n");
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值