2018中国大学生程序设计竞赛 - 网络选拔赛 Find Integer(勾股数)

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

 

 

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

 

 

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

 

 

Sample Input

 

1 2 3

 

 

Sample Output

 

4 5

题意:

已知a和n,求满足等式 a^n + b^n = c^n的任意一组b,c

思路:

若需要一组最小数为奇数的勾股数,可任意选取一个 3 或以上的奇数,将该数自乘为平方数,除以 2,答案加减 0.5 可得到两个新的数字,这两个数字连同一开始选取的奇数,三者必定形成一组勾股数。但却不一定是以这个选取数字为起首勾股数的唯一可能,例如 (27, 364, 365) 并非是以 27 为起首的唯一勾股数,因为存在另一个勾股数是 (27, 36, 45),同样也以 27 为首。

对于任何大于1的整数x,x2+1、x2-1与2x,三个数必为毕氏数,例如:代入x为2,则x2+1为5,x2-1为3,2x为4,(3,4,5)为一组毕氏数。

费马最后定理指出,若 a n + b n = c n {\displaystyle a^{n}+b^{n}=c^{n}} a^{n}+b^{n}=c^{n},而 n 是大于 2 的整数, (a, b, c) 即没有正整数解。

#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        int n,a;
        scanf("%d%d",&n,&a);
        int b=-1,c=-1;
        if(n==2){
            if(a>=3&&a%2){
                int k=a*a;
                b=k/2;
                c=k-b;
            }
            else if(a>3){
                int x=a/2;
                c=x*x+1;
                b=x*x-1;
            }
        }
        else if(n==1){
            b=1;
            c=a+1;
        }
        printf("%d %d\n",b,c);
    }

return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值