【南阳oj 】练习题 5 Binary String Matching

点击打开链接



描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int main()
{
	int n,a,b,s,w,k,e;
	char  s1[20],s2[1009];
	cin>>n;
	getchar();
	while(n--)
	{	gets(s1);
		a=strlen(s1);
		gets(s2);
		b=strlen(s2);
		w=0,e=0;
		for(int i=0;i<=b-a;i++)
		{	s=0;
			if(s2[i]==s1[0]&&a!=1)
			{	k=i;
				for(int j=1;j<a;j++)
				{
					if(s2[++k]==s1[j])
						s+=1;
				}	
			if(s==(a-1))
				w=w+1;
			}
			if(s2[i]==s1[0]&&a==1)
			{
				w++;
			}
		}
		cout<<w<<endl;
	}
	return 0;
}


题意:输入n组测试数据,每组测试数据包含两个字符串A和B,问B字符串中包含几个A字符串。

解题思路:从B字符串的第一个字符开始检测,如果与A字符串中第一个字符相等,继续检测下面字符是否与A字符串相等。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值