A1063 Set Similarity (25分)【C语言】

A1063 Set Similarity (25分)【C语言】

原题链接

用到了标准模板库中的set
set内的元素自动递增排序,且自动去除了重复元素
在本题中应用十分方便

题目描述:
Given two sets of integers, the similarity of the sets is defined to be N​c​​ /N​t​​ ×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入格式:
Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10 ​4​​ ) and followed by M integers in the range [0,10 ​9​​ ]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

输出格式:
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

输入样例:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

输出样例:

50.0%
33.3%

实现代码:

#include <cstdio>
#include <set>
using namespace std;
const int N = 51;
set<int> st[N]; //N个集合

void compare(int x, int y){
	int totalNum = st[y].size(); //不同数的个数初始化为y集合的个数 
	int sameNum = 0; //相同数的个数初始化为0 
	for(set<int>::iterator it=st[x].begin(); it!=st[x].end(); ++it){ //遍历x集合 
		if(st[y].find(*it) != st[y].end()) sameNum++; //若能在y集合中找到与x集合相同的数 
		else totalNum++; //若找不到相同的数 
	}
	printf("%.1f%\n", sameNum*100.0/totalNum);
}

int main()
{
	int n, k, q, v, st1, st2;
	scanf("%d", &n);
	for(int i=1; i<=n; ++i){
		scanf("%d", &k); //每个集合有k个元素
		for(int j=0; j<k; ++j){
			scanf("%d", &v); //读入i集合中的k个元素
			st[i].insert(v); //插入set集合中 
		} 
	}
	scanf("%d", &q); //需要查询的组数
	for(int i=0; i<q; ++i){
		scanf("%d %d", &st1, &st2);
		compare(st1, st2);
	} 
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值