POJ2393————Yogurt factory (贪心)

题目如下:
Yogurt factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9225 Accepted: 4695

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

Input

* Line 1: Two space-separated integers, N and S. 

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

Hint

OUTPUT DETAILS: 

In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units. 


大意:求做酸奶的最小费用。每周都有不同的成本和需求量。这周生产的酸奶可以储存下来给以后的周次,但每保存一周需要S的费用。

思路:简单的贪心算法。如果保存费用加上原来的成本小于这周的成本,原来就多生产一部分保存到这周来。至于为什么是正确的,简单推算一下就知道,如果(c[i]+s*(j-i))<c[j],那么到第j+1周的时候,(c[i]+s*(j-i)+s)<(c[j]+s),一个很简单的逻辑。顺着推即可。


#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <cmath>
#include <queue>
#include <cctype>
#include <string>
#include <map>
#include <set>
#include <iostream>
using namespace std;

#define INF 1e9+7
#define MAXN 10010

int n,s;
int c[MAXN],y[MAXN];


int main()
{
    scanf("%d%d",&n,&s);
    for(int i=0;i<n;i++)
        scanf("%d%d",c+i,y+i);
    long long res=0;
    int i=0;
    while(i<n)
    {
        res+=c[i]*y[i];
        int j=i+1;
        while(j<n)
        {
            if((s*(j-i)+c[i])<c[j])
            {
                res+=(c[i]+s*(j-i))*y[j];
                j++;
            }
            else
                break;
        }
        i=j;
    }
    printf("%lld\n",res);
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值