POJ268————Prime Distance(数论,素数筛)

题目:

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16193 Accepted: 4301

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.



题意:题意很简单,就是区间L到U内相隔最近的相邻素数和相隔最远的。

思路:区间素数筛模板题。但是写了很久,要注意可能从1开始,以及两端都是闭区间。


代码:

#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <string>
#include <algorithm>
#include <string>

using namespace std;

#define MAXN 1000010
#define INF 1e9+7
#define MODE 1000000

typedef long long ll;

ll L,U;

bool is_prime[MAXN];
bool is_prime_small[50000];

vector <int> res;

int main()
{
	while(scanf("%I64d%I64d",&L,&U)!=EOF){
		for(int i=0;(ll)i*i <U ;i++)
			is_prime_small[i] = true;
		for(int i=0;i<=U-L;i++)
			is_prime[i]=true;
        is_prime_small[1]=false;
        if(L==1)
            is_prime[0]=false;
        //is_prime[i-a] = true 代表了i是个素数,保证空间复杂度
		for(int i=2;(ll)i*i<=U;i++){
			if(is_prime_small[i]){
				for(int j=2*i;(ll)j*j<=U;j+=i)
					is_prime_small[j]=false;
				for(ll j=max(2LL,(L+i-1)/i)*i;j<=U;j+=i)
					is_prime[j-L]=false;
			}
		}
		res.clear();
		for(ll i=L;i<=U;i++){
			if(is_prime[i-L])
				res.push_back(i);
		}
		if(res.size()<=1){
			printf("There are no adjacent primes.\n");
			continue;
		}
		ll a1=res[0],a2=res[1],b1=res[0],b2=res[1];
		ll minn=a2-a1;
		ll maxn=b2-b1;
		for(int i=2;i<res.size();i++)
		{
			if(res[i]-res[i-1]<minn)
			{
				a1=res[i-1];
				a2=res[i];
				minn=a2-a1;
			}
			if(res[i]-res[i-1]>maxn)
			{
				b1=res[i-1];
				b2=res[i];
				maxn=b2-b1;
			}
		}
		printf("%I64d,%I64d are closest, %I64d,%I64d are most distant.\n",a1,a2,b1,b2);
	}
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值