二分贪心练习--G(烧绳子问题)

题目描述:

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed. 

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000
题目大意:给一段L的绳子,加热N度,热度系数C,绳子发生变形,长度变为L1,满足 L'=(1+n*C)*L ,求弦的中心的位移。

解题思路:

这是一个数学问题。

在比较求得的L2和用公式求得得L1时,需要用二分法对h进行查找,查找符合条件的h从而求得L2。

该题还需要控制精度,即exp。

源代码:

#include <iostream>
#include <iomanip>
#include <cmath>
#include <stdio.h>
#include <algorithm>
using namespace std;
int main()
{
    double L,N,C,L1,lp,rp,exp=1E-4,mid,R,L2;
    while (cin>>L>>N>>C)
    {
        if (L==-1)
            break;
        L1=(1+N*C)*L;
        lp=0.0;
        rp=L*0.5; //题目中讲形变长度不多于原长的一半
        while (rp-lp>exp) //exp控制精度
        {
            mid=(lp+rp)/2;   //二分法进行查找
            R=double((L*L+4*mid*mid))/(8*mid);
            L2=2*R*asin(double(L)/(2*R));
            if (L1<L2)
                rp=mid;
            else
                lp=mid;
        }
        mid=double((lp+rp))/2;
        cout<<setiosflags(ios::fixed)<<setprecision(3)<<mid<<endl;
    }
    return 0;
}


  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值