Expanding Rods (二分法)

When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion.

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.
Your task is to compute the distance by which the center of the rod is displaced.
Input
The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output
For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output
61.329
225.020
0.000
在这里插入图片描述
题意:给定一杆受热变化的方程(弯曲),由图可以看出来,弯曲成一段圆弧,然后求中心移动的距离;
解题思路:由图可以看出,变换前后的关系,也就是变化前是变化后的弧线的弦长,也就是把变换后的弧线看成一个园的某一段,而变化前就为弦长,所以中心移动的距离就是弧线最高点到弦的距离h;然后用二分法来进行查找,那么原始范围就是low=0,high=l/2,里开始二分查找mid,mid即为高h,也就是距离,然后要想的到衍生出来园的r,还得求解方程组:
1.s= 圆心角乘以r=2 θr;
2.sin θ=l/2/r;
3.r^2-(r-h) ^2=(l/2) ^2;
解出:r=(ll+4hh)/8/h;s=2rasin(l/2/r);
根据告诉的L’=(1+n
C)*L,与解出的方程可以联立起来。
解题步骤
1)首先通过找方程组,然后在进行求解,因为得通过r来找到s;
2)根据题中条件,找出最初的范围;
3)二分查找,找出适合的mid,也就是h;
4)注意,此题的数据使double类型的,所以查找结束条件的注意,不能是low<high,得给出具体的。

#include <iostream>
#include <algorithm>
#include <cmath>
#include <iomanip>
using namespace std;
int a[100005];
int main()
{
    double l,n,c;
    while(cin>>l>>n>>c)
        {
            if(l<0&&n<0&&c<0)
                break;
            double s,r,h;
            s=(1.0+n*c)*l;
            double low=0.0,high=l/2.0,mid;
            while(high-low>1e-6)
                {
                    mid=(low+high)/2;
                    r=(l*l+4*mid*mid)/8/mid;
                    if(2.0*r*asin(l/r/2.0)<s)
                        low=mid;
                    else high=mid;
                }
            h=mid;
            cout<<fixed<<setprecision(3)<<h<<endl;
        }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值