Stars--树状数组

原题:

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source


题意:二维坐标给出n个不重合的点的坐标,每个点的等级是它的左下方(包括正下方和正左方)的点的个数,需要输出每个等级的点的个数。

思路:因为输入是按照y坐标升序输入,若y坐标相同按照x坐标升序输入,则y坐标基本没用。按照x坐标建立一维树状数组,然后利用sum和add函数去求就可以了。

源代码:

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
#define MAX 1000000
using namespace std;
int L[MAX];//L[i]用来表示等级为i的点有多少个
int C[MAX];
int lowbit(int x)
{
    return x &(-x);
}
int getsum(int x)
{
    int res = 0;
    while (x > 0)
    {
        res += C[x];
        x -= lowbit(x);
    }
    return res;
}
void add(int x,int v)
{
    while (x < MAX)
    {
        C[x] += v;
        x += lowbit(x);
    }
}
int main()
{
    int n;
    while (scanf("%d",&n)!=EOF)
    {
        memset(C,0,sizeof(C));//一定要注意刚开始的时候是0
        memset(L,0,sizeof(L));
        for (int i = 0; i < n; i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            x++;//避免x = 0的点
            L[getsum(x)]++;//等级为getsum(x)的点增一
            add(x,1);
        }
        for (int i = 0; i < n; i++)
            printf("%d\n",L[i]);
    }
    return 0;
}
/*
 5
 1 1
 5 1
 7 1
 3 3
 5 5
 1
 2
 1
 1
 0
 */



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值