Can you find it?(hdu 2141)

Can you find it?

TimeLimit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K(Java/Others)
Total Submission(s): 4217 Accepted Submission(s):1049


Problem Description
Give you three sequences of numbers A,B, C, then we give you a number X. Now you need to calculate if youcan find the three numbers Ai, Bj, Ck, which satisfy the formulaAi+Bj+Ck = X.

Input
There are many cases. Every data case isdescribed as followed: In the first line there are three integersL, N, M, in the second line there are L integers represent thesequence A, in the third line there are N integers represent thesequences B, in the forth line there are M integers represent thesequence C. In the fifth line there is an integer S representsthere are S integers X to be calculated. 1<=L, N,M<=500, 1<=S<=1000.all the integers are 32-integers.

Output
For each case, firstly you have to printthe case number as the form "Case d:", then for the S queries, youcalculate if the formula can be satisfied or not. If satisfied, youprint "YES", otherwise print "NO".

Sample Input
3 3 3 1 2 31 2 3 1 2 3 3 1 4 10

Sample Output
Case 1: NOYES NO

Author
wangye

Source
如果暴力求解肯定超时,先将前两个数组合并,在进行二分查找可以降低时间复杂度。
#include<math.h>    
#include <stdio.h>    
#include <stdlib.h>    
#include <string.h>
#include <algorithm>
using namespace std;
const int N=505;
int a[N],b[N],c[N],sum[N*N];
 int find(int s,int low,int high){
    intmid;
   while(low<=high)
    {
       mid=(low+high)/2;
       if(sum[mid]==s)
           return 1;
       else if(sum[mid]>s)
       {
           high=mid-1;
       }
       else
       {
           low=mid+1;
       }
    }
    return0;
}
int main(){
    intl,n,m,s,x,i,j,su,num=1;
   while(~scanf("%d%d%d",&l,&n,&m)){
       for(i=0;i<l;i++)
           scanf("%d",&a[i]);
       for(i=0;i<n;i++)
           scanf("%d",&b[i]);
       for(i=0;i<m;i++)
           scanf("%d",&c[i]);
       su=0;
       for(i=0;i<l;i++)
           for(j=0;j<n;j++)
               sum[su++]=a[i]+b[j];
       sort(c,c+m);
       sort(sum,sum+l*n);
       scanf("%d",&s);
       printf("Case %d:\n",num++);
       while(s--){
           int flag=0;
           scanf("%d",&x);
           for (i=0;i<m;i++){
               if(find(x-c[i],0,l*n))
                   break;
           }
           if(i!=m)
               printf("YES\n");
           else
               printf("NO\n");
       }
    }
    return0;
}
 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值