Monthly Expense--(二分)

Monthly Expense

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 35   Accepted Submission(s) : 12
Problem Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

 

Input
Line 1: Two space-separated integers: <i>N</i> and <i>M</i> <br>Lines 2..<i>N</i>+1: Line <i>i</i>+1 contains the number of dollars Farmer John spends on the <i>i</i>th day
 

Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
 

Sample Input
 
 
7 5100400300100500101400
 

Sample Output
 
 
500

就是求把数组分为连续的m段,使得和最大的一段的和尽量小,求出这个最大和,很经典的一种二分方式

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
#define inf 1000000
int n,m,a[100010];
int main()
{
    int i,cnt,sum,left,right,mid;
    scanf("%d%d",&n,&m);
    cnt=sum=0;
    for(i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
        if(cnt<a[i]) cnt=a[i];
        sum+=a[i];
    }
    left=cnt; right=sum;  //给left,right找到上下限是很重要的一步
    while(left<right)
    {
        mid=(left+right)/2; //mid枚举最大的fjmonth花费的值,通过二分找mid正确值
        cnt=sum=0;
        for(i=0;i<n;i++)
        {
            sum+=a[i];
            if(sum>mid)  //加上a[i]后子段和大于了mid所以不能加a[i]于是i--,但是此时a[i]之前的新子段正好分好了且不大于mid
            {
                sum=0;
                cnt++;   //cnt记录用mid可以将n分为几段
                i--;
            }
        }
        cnt++; //加上剩下的一组
        if(cnt>m) left=mid+1;
        else right=mid-1;
    }
    printf("%d",left);
    return 0;
}


  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
首先,需要在GEE中导入Landsat-8图像。在GEE中,可以使用以下代码导入Landsat-8图像: ```javascript var L8 = ee.ImageCollection('LANDSAT/LC08/C01/T1_SR'); var image = L8.filterDate('2019-01-01', '2019-12-31') .filterBounds(geometry) .sort('CLOUD_COVER') .first(); ``` 其中,`filterDate`和`filterBounds`分别用于按时间和区域筛选图像,`sort`用于按云量排序,`first`用于选择云量最小的图像。 接下来,需要对图像进行大气校正。在GEE中,可以使用以下代码进行大气校正: ```javascript // 定义参数 var aeroModel = 'MODTRAN'; // 大气校正模型 var elevation = ee.Image('USGS/SRTMGL1_003'); // 地形高度 var waterVapor = 'MOD08_D3'; // 水汽数据集 var ozone = 'OMI/AURA/OMTO3/Monthly'; // 臭氧数据集 var year = image.date().get('year'); // 根据图像日期获取年份 // 进行大气校正 var corrImage = ee.Algorithms.Landsat.simpleCloudScore(image).select(['B2', 'B3', 'B4', 'B5', 'B6', 'B7', 'B10', 'B11']); corrImage = ee.Algorithms.Landsat.correctRadiometry(corrImage); corrImage = ee.Algorithms.Landsat.calibrate(corrImage); corrImage = ee.Algorithms.Landsat.TOA(corrImage); corrImage = ee.Algorithms.Landsat.simpleCloudScore(corrImage).select(['B2', 'B3', 'B4', 'B5', 'B6', 'B7', 'B10', 'B11']); corrImage = ee.Algorithms.Landsat.atmosphericCorrection(corrImage, elevation, aeroModel, ozone, waterVapor, year); ``` 在上述代码中,`ee.Algorithms.Landsat.simpleCloudScore`用于计算云量,`ee.Algorithms.Landsat.correctRadiometry`用于矫正辐射定标系数,`ee.Algorithms.Landsat.calibrate`用于定标反射率,`ee.Algorithms.Landsat.TOA`用于将反射率转换为顶部大气反射率,`ee.Algorithms.Landsat.atmosphericCorrection`用于进行大气校正。 最后,可以使用以下代码将大气校正后的图像可视化: ```javascript Map.addLayer(corrImage, {bands:['B4', 'B3', 'B2'], min:0, max:0.3}, 'Corrected Image'); ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值