hdu - 2588 - GCD(欧拉函数求同值gcd个数)

 

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6. 
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem: 
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output

For each test case,output the answer on a single line.

Sample Input

3
1 1
10 2
10000 72

Sample Output

1
6
260

 

 

题目给出n、m,让求满足gcd(x,n)>=m(1<=x<=n)的个数

对于此种题目,先枚举n的所有因子,对于每一个大于m因子k若gcd(i,n)=k,我们可以求出i的个数,即将gcd(i,n)=k转化为gcd(i/k,n/k)=1;那么i/k与n/k互质,即n/k的欧拉函数值就是i的个数。这里只统计大于等于m的因子。这段的意思就是取n的所有大于等于m的因子k,统计gcd(i,n)=k的i个数。

这里只需枚举到sqrt(n),因为另一个因子是对称的(n/i)

如果n为完全平方数,则i==n/i,即sqrt(n)的欧函数只需加一次

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;
#define mod 1000000007

int n,m;
int euler_phi(int n)
{
    int ans=n;
    for(int i=2;i*i<=n;i++)
    if(n%i==0)
    {
        ans-=ans/i;
        while(n%i==0)
            n/=i;
    }
    if(n>1)
        ans-=ans/n;
    return ans;
}

int main()
{
    int i,T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);

        ll ans=0;
        for(i=1;i*i<n;i++)
        if(n%i==0)
        {
            if(i>=m)
            {
                ans+=euler_phi(n/i);
            }
            if(n/i>=m)
            {
                ans+=euler_phi(i);
            }
        }

        if(i*i==n&&i>=m)
            ans+=euler_phi(i);
        printf("%lld\n",ans);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值