HDU - 1695 - GCD - (容斥定理,欧拉函数)

 

Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs. 
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same. 

Yoiu can assume that a = c = 1 in all test cases. 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases. 
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above. 

Output

For each test case, print the number of choices. Use the format in the example. 

Sample Input

2
1 3 1 5 1
1 11014 1 14409 9

Sample Output

Case 1: 9
Case 2: 736427


        
  

Hint

For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

 

 

题意:给出a,b,c,d,k,求有多少对[x,y],其中x属于[a,b],y属于[c,d]使得gcd(x,y)=k;且有a,c始终为1,(x,y)与(y,x)视为同一种情况。

那么找gcd(x,y)=k,等于找gcd(x/k,y/k)=1;即从区间[1,b/k]与[1,d/k]中各取一个数,且这两个数互质的情况,那么这个问题可以转换为求对于区间[1,d/k]中每个数,在区间[1,b/k]中有多少个数与其互质,最后再求和。

1.对于区间[1,d/k]中小于b/k的数,他们在区间[1,b/k]中互质的数的总和为phi[1]+phi[2]+.......phi[b/k].

2.对于区间[1,d/k]中大于b/k的数,每个数i在区间[1,b/k]中与其互质的数的个数,可以通过求其在在区间[1,b/k]中与其不互质的数的个数,再做减法。这一步就用容斥定理来做。找出[1,b/k]中可以被i的每个质因子整除的数的个数求和,减去可以被其任意两个质因子整除的数的个数,加上可以被其任意三个质因子整除的数的个数。。。。。。

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;
#define M 100005

int phi[M],prime[100];
int a,b,c,d,k;

void euler_phi()
{
    int i,j;
    //memset(phi,0,sizeof(phi));
    phi[1]=1;
    for(i=2;i<=100000;i++)
    if(!phi[i])
    {
        for(j=i;j<=100000;j+=i)
        {
            if(!phi[j])
                phi[j]=j;
            phi[j]=phi[j]/i*(i-1);
        }
    }
}

ll slove(int n)   //求区间1~b中有多少数与n不互质
{
    //memset(prime,0,sizeof(prime));
    int i,num=0;
    for(i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            prime[num++]=i;
            while(n%i==0)
                n=n/i;
        }
    }
    if(n!=1)
        prime[num++]=n;

    ll sum=0;
    for(ll msk=1;msk<(1ll<<num);msk++)
    {
        ll mult=1,bits=0;
        for(ll i=0;i<num;i++)
        {
            if(msk&(1ll<<i))
            {
                bits++;
                mult*=prime[i];
            }
        }
        if(bits&1)
            sum+=((ll)b)/mult;
        else
            sum-=((ll)b)/mult;
    }
    return sum;
}

int main()
{
    euler_phi();
    int i,T,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        if(k==0)
        {
            printf("Case %d: 0\n",++cas);
            continue;
        }
        if(b>d)
        {
            int temp=b;
            b=d;
            d=temp;
        }
        ll ans=0;
        b=b/k;
        d=d/k;
        for(i=1;i<=b;i++)
        {
            ans+=phi[i];
        }
        for(i=b+1;i<=d;i++)
        {
            ans+=(ll)b-slove(i);
        }
        printf("Case %d: %lld\n",++cas,ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值