POJ - 2409 - Let it Bead - (Polya定理)

Description

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced. 

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.

Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

Output

For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output

1
2
3
5
8
13
21

Polya定理:设G是n个对象的一个置换群,用m种颜色涂染这n个对象,则不同染色的方案数L=1/|G|*[m^p(a1)+m^p(a2)+....+m^p(ak)].其中p(ai)是某个置换的循环节数,|G|即是置换的个数.

1.旋转置换.

我们假设依次顺时针旋转1~n个,每种旋转为一种置换,则旋转i个的置换循环节数=gcd(i,n);

2.翻转置换

当n为偶数时,分两种情况,每种情况有n/2种置换,一种是中心轴在两个对称对象上,则每种置换的循环节数为n/2+1,另一种是对称轴两边分别有n/2个对象,则每种置换的循环节数为n/2;

当n为奇数时,有n个置换对称轴就只能在一个对象上,则循环个数为n/2+1;

Polya定理的使用主要是找出每种置换以及每种置换的循环节数。题目中这两种循环节求法可做公式使用。

Polya定理见: 

Polya定理

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<math.h>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;

int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}

ll polya(int n,int m)
{
    if(n==0)
        return 0;
    ll sum=0;
    for(int i=1;i<=n;i++) //旋转i对应置换的循环个数为gcd(n,i)
        sum+=pow(1.0*m,gcd(n,i));
    if(n&1)   //反转对饮置换的循环个数分奇偶讨论
        sum+=n*pow(1.0*m,(n+1)/2);
    else
        sum+=n/2*(pow(1.0*m,(n+2)/2)+pow(1.0*m,n/2));
    return sum/(2*n);
}

int main()
{
    int s,c;
    while(scanf("%d%d",&c,&s)!=EOF)
    {
        if(s==0&&c==0)
            break;
        printf("%I64d\n",polya(s,c));
    }
    return 0;
}

参考: https://wenku.baidu.com/view/bf92a95f804d2b160b4ec0be.html

http://blog.csdn.net/shiren_Bod/article/details/5664934/

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值