POJ 3625 Building Roads

Building Roads

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13249 Accepted: 3662

Description

Farmer John had just acquired several new farms! He wants to connect the farms with roads so that he can travel from any farm to any other farm via a sequence of roads; roads already connect some of the farms.

Each of the N (1 ≤ N ≤ 1,000) farms (conveniently numbered 1..N) is represented by a position (XiYi) on the plane (0 ≤ Xi ≤ 1,000,000; 0 ≤ Yi ≤ 1,000,000). Given the preexisting M roads (1 ≤ M ≤ 1,000) as pairs of connected farms, help Farmer John determine the smallest length of additional roads he must build to connect all his farms.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Two space-separated integers: Xi and Yi 
* Lines N+2..N+M+2: Two space-separated integers: i and j, indicating that there is already a road connecting the farm i and farm j.

Output

* Line 1: Smallest length of additional roads required to connect all farms, printed without rounding to two decimal places. Be sure to calculate distances as 64-bit floating point numbers.

Sample Input

4 1
1 1
3 1
2 3
4 3
1 4

Sample Output

4.00

Source

USACO 2007 December Silver

给你n个牧场的坐标,已经有m条路连接一部分农场,

问:需要多长新的路才能将所有牧场连接

//最小生成树模板

不需要处理小数点后两位的格式,直接输出就行。

//注意需要用 printf("%.2f",sum); 输出

//不能用 printf("%.2lf",sum); 

This is the codes:

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
#define LL long long
#define ULL unsigned long long     //1844674407370955161
#define INT_INF 0x7f7f7f7f      //2139062143
#define LL_INF 0x7f7f7f7f7f7f7f7f //9187201950435737471
// ios::sync_with_stdio(false);
// 那么cin, 就不能跟C的 scanf,sscanf, getchar, fgets之类的一起使用了。
const int dr[]= {0, 0, -1, 1, -1, -1, 1, 1};
const int dc[]= {-1, 1, 0, 0, -1, 1, -1, 1};
struct node
{
    double x,y;
} a[1050];
struct Node
{
    int u;
    int v;
    double dis;//距离
    Node() {}
    Node(int u,int v,double dis):u(u),v(v),dis(dis) { }
    bool operator < (const Node &rhs)const
    {
        return dis > rhs.dis;//小根推,距离短的在前面的在前面
    }
};//储存树.
int num=0;
priority_queue<Node> edges;
int fa[1050];

int Find(int x)
{
    if(fa[x]==x)
        return x;
    return fa[x]=Find(fa[x]);
}
double S(double x,double y)//求距离
{
    return sqrt(x*x+y*y);
}
void init(int n)//一定要初始化
{
    for(int i=0; i<=n; ++i)
        fa[i]=i;
    while(!edges.empty())
        edges.pop();
}
void Kruskal(int n)//求最小生成树
{

    double sum=0;
    while(!edges.empty())
    {

        Node x=edges.top();
        edges.pop();
        int u=Find(x.u);
        int v=Find(x.v);
        if(u!=v)
        {
            fa[u]=v;
            num++;
            sum+=x.dis;
        }
        if(num>=n)
            break;
    }
    //LL ans1=sum*100;
    //double ans2=ans1*1.0/100.0;
    printf("%.2f\n",sum);
}
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    init(n);
    for(int i=1; i<=n; i++)
        scanf("%lf%lf",&a[i].x,&a[i].y);
    for(int i=1; i<=n; i++ )
    {
        for(int j=i+1; j<=n; j++ )
        {
            double tem= S(a[i].x-a[j].x,a[i].y-a[j].y);//长度
            edges.push(Node(i,j,tem));
        }
    }

    for(int i=1; i<=m; i++)
    {
        int u,v;
        scanf("%d%d",&u,&v);
        edges.push(Node(u,v,0));
        int uu=Find(u);
        int vv=Find(v);
        if(uu!=vv)
        {
            fa[uu]=vv;
            num++;
        }
    }
    Kruskal(n-1);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值