POJ - 3348 Cow(凸包面积)

问题:

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input
4
0 0
0 101
75 0
75 101
Sample Output
151

题目大意:

牧场里有一些树,给出树的坐标,让你求凸包,并且求凸包面积,

解题思路:

套模板就好了。

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>

using namespace std;
const int maxn = 10005;
const double eps = 1e-8;
const double PI = acos(-1.0);
const int inf = 0x3f3f3f3f;

//对于浮点数的,><=0的判断。
int sgn(double x)
{
    if(fabs(x)<eps) return 0;
    if(x<0) return -1;
    else return 1;
}
struct Point
{
    double x, y;
    Point() {}
    Point(double _x, double _y)
    {
        x = _x;
        y = _y;
    }
    Point operator -(const Point &b)const
    {
        return Point(x-b.x,y-b.y);
    }
    Point operator +(const Point &b)const
    {
        return Point(x+b.x,y+b.y);
    }
    //叉积
    double operator ^(const Point &b)const
    {
        return x*b.y-y*b.x;
    }
    //点积
    double operator *(const Point &b)const
    {
        return x*b.x+y*b.y;
    }
    //绕原点旋转角度B(弧度制)后,x,y的变化。
    void transXY(double B)
    {
        double tx = x, ty = y;
        x = tx*cos(B)-ty*sin(B);
        y = tx*sin(B)+ty*cos(B);
    }
};
double dist(Point a, Point b)
{
    //勾股定理,使用点积
    return sqrt((a-b)*(a-b));
}

Point p[maxn];
int n;

//做极角排序
bool _cmp(Point p1,Point p2)
{
    double tmp = (p1-p[1])^(p2-p[1]); //向量叉乘
    if(sgn(tmp)>0) return true;
    else if(sgn(tmp)==0&&sgn(dist(p1,p[1])-dist(p2,p[1]))<=0)
        return true;
    else return false;
}

int Stack[maxn],top;

void Graham()
{
    Point p0;
    int k = 1;
    p0 = p[1];
    //找最下方的一个点
    for(int i = 2; i <= n; i++)
    {
        if(p0.y>p[i].y||(p0.y==p[i].y&&p0.x>p[i].x))
        {
            p0 = p[i];
            k = i;
        }
    }
    swap(p[1],p[k]);
    sort(p+2,p+n+1,_cmp);
    if(n == 1)
    {
        top = 1;
        Stack[0] = 1;
        return ;
    }
    if(n == 2)
    {
        top = 2;
        Stack[0] = 1;
        Stack[1] = 2;
        return ;
    }
    Stack[0] = 1;
    Stack[1] = 2;
    top = 2;
    for(int i = 3; i <= n; i++)
    {
        while(top>1&&sgn((p[Stack[top-1]]-p[Stack[top-2]])^(p[i]-p[Stack[top-2]]))<=0) top--;
        Stack[top++] = i;
    }

}

//计算多边形的面积
//点的编号从0到n-1;
Point pp[maxn];
double CalcArea()
{
    double res = 0;
    for(int i = 0; i < top; i++)
        res += (pp[i]^pp[(i+1)%top])/2;
    return fabs(res);
}


int main()
{

    scanf("%d", &n);
    for(int i = 1; i <= n; i++)
    {
        scanf("%lf%lf", &p[i].x, &p[i].y);
    }
    Graham();
    for(int i = 0; i < top; i++)
    {
        pp[i] = p[Stack[i]];
    }
    int g = CalcArea()/50;
    printf("%d\n",g);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值