Cows (能容纳多少头牛)

POJ - 3348 

Description

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151

 

题目大意:给你n个点,输入这n个点的坐标,让你求出由这n个点围成的多边形的面积,每头牛生活的面积是50平方米,用你求出来的多边形的面积除以50,就是能生存的牛的头数。

任务就是求出已知坐标的点围成的多边形面积,利用求凸包的面积可以很方便解决这个问题。

代码如下:

​
#include <stdio.h>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

struct pt{
	int x;
	int y;
}a[10000],b[10000];

int cmp(pt a,pt b){           //比较函数 
	if(a.x==b.x) return a.y<b.y;
	return a.x<b.x;
}

inline pt jj (pt a,pt b){     //向量减法 
	pt c;
	c.x=a.x-b.x,c.y=a.y-b.y;
	return c;
}

double det(pt a,pt b){          //求叉积函数 
	return (a.x*b.y-a.y*b.x);
}

double PolygonArea(pt *p,int n){      //多边形面积 
	double area=0;
	for(int i=1;i<n-1;i++){
		area+=det(jj(p[i],p[0]),jj(p[i+1],p[0]));
	}
	return fabs(area/2);
}

int ConvexHull (pt * p,int n, pt * ch ){   //凸包 
	sort (p,p+n,cmp );
	int m=0;
	for (int i=0;i<n;i++){
	while (m>1 && det(jj(ch[m-1],ch[m-2]),jj(p[i],ch[m-2]))<=0) m--;
	ch[m++]=p[i];
	}
	int k=m;
	for (int i=n-2;i>=0;i--){
	while(m>k && det(jj(ch[m-1],ch[m-2]),jj(p[i],ch[m-2]))<=0) m--;
	ch[m++]=p[i];
	}
	if(n>1) m--;
	return m;
}

int main(){

	int s,n,m;
	cin>>n;
	for(int i=0;i<n;i++){
		scanf("%d %d",&a[i].x,&a[i].y);
	}
	m = ConvexHull(a,n,b);
	s = PolygonArea(b,m);
	cout<<s/50<<endl;
	
	return 0;
}

​

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值