POJ-3278-Catch That Cow

题目信息:

Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 orX + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:有一个农民和一头牛,他们在一个数轴上,牛在k位置保持不动,农户开始时在n位置。设农户当前在M位置,每次移动时有三种选择:1.移动到M-1;2.移动到M+1位置;3.移动到M*2的位置。问最少移动多少次可以移动到牛所在的位置。所以可以用广搜来搜索这三个状态,直到搜索到牛所在的位置。


代码部分:

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int N, K;
struct Node
{
	int x;
	int steps;
}node, t;
bool vis[200005];
void BFS()
{
	queue<Node>D;
	D.push(node);
	while(!D.empty())
	{
		node = D.front();
		D.pop();
		if(node.x == K)
		{
			printf("%d\n", node.steps);
			break;
		}
		node.steps++;
		if(node.x > 0 && !vis[node.x - 1])
		{
			t = node;
			t.x--;
			D.push(t);
			vis[t.x] = true;
		} 
		if(node.x < K && !vis[node.x + 1])
		{
			t = node;
			t.x++;
			D.push(t);
			vis[t.x] = true;
		}
		if(node.x < K && !vis[node.x * 2])
		{
			t = node;
			t.x *= 2;
			D.push(t);
			vis[t.x] = true;
		}
	}
}
int main()
{
	while(scanf("%d%d", &N, &K) != EOF)
	{
		memset(vis, false, sizeof(vis));
		node.x = N;
		node.steps = 0;
		vis[N] = true;
		BFS();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值