poj1753Flip Game

poj1753Flip Game
Time Limit: 1000 ms / Memory Limit: 65536 kb
Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it’s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Choose any one of the 16 pieces.
Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here “b” denotes pieces lying their black side up and “w” denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input
The input consists of 4 lines with 4 characters “w” or “b” each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it’s impossible to achieve the goal, then write the word “Impossible” (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww
Sample Output
4
Source
Northeastern Europe 2000

这个题真的很好,bfs + 状态压缩,我做了几遍,见到之后还是有点不会

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
//bfs + 状态压缩
//好题,由于黑白是两种状态,可用0,1来表示,所以可用状态压缩(一个数)来表示棋盘的状态
#define N (1 << 15 + 1)
//count代表当前棋盘状态是至少翻转了几个棋子之后才成为的
//visit = true代表当前棋盘状态出现过,不需要再从这个状态继续遍历
//visit = false代表棋盘状态未出现过,将当前的数(即棋盘状态)入队列
typedef struct Node{
    int count;
    bool visit;
}Node;
Node node[N];
//check函数用来检测翻转点是否在棋盘之外
bool check(int i,int j)
{
    if(i < 0 || i > 3)
        return false;
    if(j < 0 || j > 3)
        return false;
    return true;
}
void Init()
{
    for(int i = 0;i < N;++i)
    {
        node[i].count = 0;
        node[i].visit = false;
    }
    char s;
    int n = 0;
    for(int i = 0;i < 16;++i)
    {
        cin >> s;
        n *= 2;
        if(s == 'b')
            n += 1;
    }
    if(n == 0 || n == N - 1)
    {
        cout << "0" << endl;
        return;
    }
    //cout << n << endl;
    queue<int>que;
    que.push(n);
    node[n].visit = true;
    while(!que.empty())
    {
            int t = que.front();
            que.pop();
            for(int i = 0;i < 4;++i)
            {
                for(int j = 0;j < 4;++j)
                {
                    int m = t;
                    int pos = 4 * i + j;
                    //这里是写错的代码,因为我把i和j弄反了
                    /*m ^= 1<<(15 - pos);
                    if(check(i + 1,j))
                        m ^= 1<<(16 - pos);
                    if(check(i - 1,j))
                        m ^= 1<<(14 - pos);
                    if(check(i,j - 1))
                        m ^= 1<<(11 - pos);
                    if(check(i,j + 1))
                        m ^= 1<<(19 - pos);*/
                    m ^= 1<<(15-pos);
                    if(check(i-1,j))
                        m ^= 1<<(19-pos);
                    if(check(i,j-1))
                        m ^= 1<<(16-pos);
                    if(check(i,j+1))
                        m ^= 1<<(14-pos);
                    if(check(i+1,j))
                        m ^= 1<<(11-pos);
                    //cout << m << endl;
                    node[m].count = node[t].count + 1;
                    //node[m].visit = true;
                    if(m == 0 || m == N - 1)
                    {
                        cout << node[m].count << endl;
                        return ;
                    }
                    if(node[m].visit == false)
                    {
                        node[m].visit = true;
                        que.push(m);
                    }
                }
            }
    }
    cout << "Impossible" << endl;
}
int main()
{
    //cout << N << endl;
    Init();
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值