POJ 1125 Stockbroker Grapevine

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32943 Accepted: 18123

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10


意:此题题意远比题目难
首先,题目可能有多组测试数据,每个测试数据的第一行为经纪人数量N(当N=0时,输入数据结束),
然后接下来N行描述第i(1<=i<=N)个经纪人与其他经纪人的关系(教你如何画图)。
每行开头数字M为该行对应的经纪人有多少个经纪人朋友(该节点的出度,可以为0),
然后紧接着M对整数,每对整数表示成a,b,则表明该经纪人向第a个经纪人传递信息需要b单位时间
(即第i号结点到第a号结点的孤长为b),整张图为有向图,即弧Vij 可能不等于弧Vji(数据很明显,这里是废话)。
当构图完毕后,求当从该图中某点出发,将“消息”传播到整个经纪人网络的最小时间,
输出这个经纪人号和最小时间。最小时间的判定方式为——从这个经纪人(结点)出发,
整个经纪人网络中最后一个人接到消息的时。如果有一个或一个以上经纪人无论如何无法收到消息,
输出“disjoint”(有关图的连通性,你们懂得,但据其他同学说,POJ测试数据中不会有,就是说,你不判定,
一样能过,题目数据够水的)。
分析:说的很清楚了,最短路算法基本都能水过,可以选熟悉的用
强调:floyd算法用前一定初始化为INF,否则会很惨。


#include <stdio.h>
#include <string.h>
int map[110][110];
int main()
{
	int N, i, j, x, t, ans;
	while(scanf("%d", &N) && N)
	{
		memset(map, 0x3f, sizeof(map));
		for(i = 1; i <= N; i++)
		{
			scanf("%d", &x);
			while(x--)
			{
				scanf("%d", &t);
				scanf("%d", &map[i][t]);
			}
		}
		for(t = 1; t <= N; t++)
			for(i = 1; i <= N; i++)
				for(j = 1; j <= N; j++)
					if(map[i][j] > map[i][t] + map[t][j])
						map[i][j] = map[i][t] + map[t][j];
		ans = 0x3f3f3f3f;
		for(i = 1; i <= N; i++)
		{
			x = 0;
			for(j = 1; j <= N; j++)
				if(map[i][j] > x && i != j)
					x = map[i][j];
			if(x < ans)
			{
				ans = x;
				t = i;
			}
		}
		printf("%d %d\n", t, ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值