poj 1125(Stockbroker Grapevine)Dijkstra算法

 

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17918 Accepted: 9671

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

 
#include<cstdio>
#include<iostream>
#include<cstdlib>

#define MAXN 110

using namespace std;

const int maxnum = 100;
const int maxint = 999999;

// 各数组都从下标1开始
int dist[MAXN];     // 表示当前点到源点的最短路径长度
int prev[MAXN];     // 记录当前点的前一个结点
int arr[MAXN][MAXN];   // 记录图的两点间路径长度
int n, line;// 图的结点数和路径数
int maxii[MAXN];
void Dijkstra(int n, int v, int *dist, int *prev, int arr[MAXN][MAXN])
{
	bool s[MAXN];    // 判断是否已存入该点到S集合中
	for(int i=1; i<=n; ++i)
	{
		dist[i] = arr[v][i];
		s[i] = 0;     // 初始都未用过该点
		if(dist[i] == maxint)
			prev[i] = 0;
		else
			prev[i] = v;
	}
	dist[v] = 0;
	s[v] = 1;
	// 依次将未放入S集合的结点中,取dist[]最小值的结点,放入结合S中
	// 一旦S包含了所有V中顶点,dist就记录了从源点到所有其他顶点之间的最短路径长度
	for(int i=2; i<=n; ++i)
	{
		int tmp = maxint;
		int u = v;
		// 找出当前未使用的点j的dist[j]最小值
		for(int j=1; j<=n; ++j)
			if((!s[j]) && dist[j]<tmp)
			{
				u = j;              // u保存当前邻接点中距离最小的点的号码
				tmp = dist[j];
			}
		s[u] = 1;    // 表示u点已存入S集合中

		// 更新dist
		for(int j=1; j<=n; ++j)
			if((!s[j]) && arr[u][j]<maxint)
			{
				int newdist = dist[u] + arr[u][j];
				if(newdist < dist[j])
				{
					dist[j] = newdist;
					prev[j] = u;
				}
			}

	}
	int tmp = 0;
	for(int k = 1; k <= n; k++){
        if(dist[k] > tmp && v != k){
            tmp = dist[k];
            maxii[v] = tmp;
        }
    }
}
int flag= 0;
int main(){
    int n;
    while(scanf("%d", &n),n){
        for(int i = 0; i <= n; i++){
            for(int j = 0; j <= n; j++){
                arr[i][j] = maxint;
            }
        }
    for(int i = 1; i <= n; i++){
        int m;
        scanf("%d", &m);
        if(m == 0)  continue;
        else{
            for(int j = 1; j <= m; j++){
                int a, b;
                scanf("%d%d", &a, &b);
                arr[i][a] = b;
            }
        }
    }

    for(int j = 1; j <= n; j++){
        Dijkstra(n,j, dist,prev,arr);
    }

    maxii[0] = 110;
    for(int j = 1; j<= n; j++){
        if(maxii[j] < maxii[0])  {
            maxii[0] = maxii[j];
            flag = j;
        }
    }
            printf("%d %d\n",flag, maxii[0]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值