POJ 2828 Buy Tickets

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 17515 Accepted: 8700

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The nextN lines contain the pairs of values Posi and Vali in the increasing order ofi (1 ≤ iN). For each i, the ranges and meanings ofPosi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind thePosi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the valueVali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.


题意:

输入n个有序对<pi, vi> pi表示在第pi个位置后面插入一个值为vi的人,并且pi是不降的。

输出最终得到的v的序列。

线段树,记录区间内的空位置数,反过来将人插入到序列中。

#include <stdio.h>
#define lson l,m,root<<1
#define rson m+1,r,root<<1|1
#define maxn 222222
int Tree[maxn<<2];
int Seq[maxn],Pos[maxn],Val[maxn];
int id;
void build(int l, int r, int root)
{
	Tree[root] = r - l + 1;
	if(l == r)
		return;
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
}
int find(int p, int l, int r, int root)
{
	Tree[root]--;	
	if(l == r)
		return l;
	int m = (l + r) >> 1;
	if(Tree[root<<1] >= p)
		return find(p, lson);
	else
		return find(p - Tree[root<<1], rson);
}
int main()
{
	int n, i;
	while(scanf("%d", &n) != EOF)
	{
		build(1, n, 1);
		for(i = 1; i <= n; i++)
			scanf("%d%d", &Pos[i], &Val[i]);
		for(i = n; i >= 1; i--)
			Seq[find(Pos[i] + 1, 1, n, 1)] = Val[i];
		printf("%d", Seq[1]);
		for(i = 2; i <= n; i++)
			printf(" %d", Seq[i]);
		printf("\n");
	}
	return 0;
}

树状数组:

#include <stdio.h>
#define N 222222
int n;
int Tree[N];
int Seq[N], Pos[N], Val[N];
int lowbit(int i)
{
	return i & -i;
}
void add(int i, int x)
{
	while(i <= n)
	{
		Tree[i] += x;
		i += lowbit(i);
	}
}
int getPos(int x)
{
	int ans = 0, cnt = 0;
	for (int i = 18; i >= 0; i--)
	{
		ans += (1 << i);
		if (ans >= n || cnt + Tree[ans] >= x)
			ans -= (1 << i);
		else
			cnt += Tree[ans];
	}
	return ans + 1;
}
int main()
{
	while(~scanf("%d", &n))
	{
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &Pos[i], &Val[i]);
			add(i, 1);
		}
		for (int i = n; i >= 1; i--)
		{
			int p = getPos(Pos[i] + 1);
			Seq[p] = Val[i];
			add(p, -1);
		}
		printf("%d", Seq[1]);
		for(int i = 2; i <= n; i++)
		{
			printf(" %d", Seq[i]);
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值