POJ 2139 Six Degrees of Cowvin Bacon

Six Degrees of Cowvin Bacon
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4239 Accepted: 2008

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]


和这一题很像:http://blog.csdn.net/sdfgdbvc/article/details/51164791

都是路线内站点两两互相关系为1,每换一个路线两点关系+1,求最短路径

#include <stdio.h>
#include <string.h>
int N, M;
int map[305][305];
int group[305];
int main()
{
	int i, j, k, x, max;
	while(scanf("%d%d", &N, &M) != EOF)
	{
		memset(map, 0x3f, sizeof(map));
		for(i = 1; i <= N; i++)
			map[i][i] = map[i][0] = 0;	
		for(i = 1; i <= M; i++)
		{
			scanf("%d", &x);
			for(j = 1; j <= x; j++)
				scanf("%d", &group[j]);
			for(j = 1; j <= x; j++)
				for(k = j + 1; k <= x; k++)
					map[group[j]][group[k]] = map[group[k]][group[j]] = 1;
		}
		for(k = 1; k <= N; k++)
			for(i = 1; i <= N; i++)
				for(j = 1; j <= N; j++)
					if(map[i][j] > map[i][k] + map[k][j])
						map[i][j] = map[i][k] + map[k][j];	
		for(i = 1; i <= N; i++)
			for(j = 1; j <= N; j++)
				map[i][0] += map[i][j];
		max = 0x3f3f3f3f;
		for(i = 1; i <= N; i++)
			if(map[i][0] < max)
				max = map[i][0];
		printf("%d\n", (int)(100*((double)max / (N - 1))));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值