poj 1195 Mobile phones(二维的树状数组)得好好看。。。

1、http://poj.org/problem?id=1195

2、题目大意

给定4种操作,分别是

操作0的意思是创建一个S*S的空矩阵

操作1的意思是将矩阵中的(X,Y)位值的数字加上A

操作2的意思是求出左上角坐标是(L,B),右下角坐标是(R,T),求这一个矩形内的所有点的值的和

操作3是样例结束符

3、题目分析

乍一看题目好像挺简单的,不就是操作一个矩阵嘛,从头遍历查询求和就行,问题就在这,矩阵很大,查询次数多,而且这个矩阵还是在不断变化的,所以简单的二维数组时无法实现的,这道题目用到的是二维的树状数组,头不难,但是作为第一道二维的题目还是不简单的

对于最终的结果ll ans=getSum(x2,y2)-getSum(x1-1,y2)-getSum(x2,y1-1)+getSum(x1-1,y1-1);

只要画个矩形就能很容易的看出来

4、题目:

Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 13691 Accepted: 6352

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source

5、AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1030
#define ll long long
int c[N][N];
int n;
int lowbit(int i)
{
    return i&(-i);
}
void update(int x,int y,int a)
{
    for(int i=x;i<=n;i+=lowbit(i))
    {
        for(int j=y;j<=n;j+=lowbit(j))
        {
            c[i][j]+=a;
        }
    }
}
ll getSum(int x,int y)
{
    ll sum=0;
    for(int i=x;i>0;i-=lowbit(i))
    {
        for(int j=y;j>0;j-=lowbit(j))
        {
            sum+=c[i][j];
        }
    }
    return sum;
}

int main()
{
    int op,x,y,a,x1,y1,x2,y2;
    while(scanf("%d",&op)!=EOF)
    {
        if(op==3)
        break;
        if(op==0)
        {
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    c[i][j]=0;
                }
            }
        }
        else if(op==1)
        {
            scanf("%d%d%d",&x,&y,&a);
            //下标从0开始,首先都后移一位
            x++;
            y++;
            update(x,y,a);
        }
        else if(op==2)
        {
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            x1++;
            y1++;
            x2++;
            y2++;
            //printf("*%lld %lld %lld %lld\n",getSum(x2,y2),getSum(x1-1,y2),getSum(x2,y1-1),getSum(x1-1,y1-1));
            ll ans=getSum(x2,y2)-getSum(x1-1,y2)-getSum(x2,y1-1)+getSum(x1-1,y1-1);
            printf("%lld\n",ans);
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值