整数拆分为2的幂之和POJ 2229

参考博客分析http://blog.csdn.net/u013486414/article/details/48035567

Sumsets

POJ - 2229                             

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input
A single line with a single integer, N.
Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
Sample Input
7
Sample Output
6
可以用递推,对于一个整数n,分为奇数和偶数,我们应该分情况讨论。 
 1.如果为奇数,那么在这个表示中一定含有一个1,把这个1减去,就是n-1 
 即dp[n]=dp[n-1]。 
 2.如果为偶数,那么也分两种情况,有1和没1。对于有1的情况可以直接拆出两个1,然后变为n-2的情况。对于没有1的情况可以直接将其转化为n/2,因为n拆分出所有的数字都是2的倍数,只需要将每种拆分结果中的数字都除以2就会与n/2的一种拆分相对应。
#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
long long dp[1000001];

int main()
{
    dp[1] = 1;
    dp[2] = 2;
    for(int i = 3; i <= 1000000; i ++)
    {
        if(i&1)
            dp[i] = dp[i-1];
        else
            dp[i] = dp[i-2] + dp[i/2];
    }
    int n;
    scanf("%d", &n);
    printf("%lld\n", dp[n]%1000000000);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值