LIS代表Longest Increasing Subsequence
Longest Ordered Subsequence
A numeric sequence of ai is ordered ifa1 < a2 < ... <aN. Let the subsequence of the given numeric sequence (a1, a2, ...,aN) be any sequence ( ai1,ai2, ...,aiK), where 1 <=i1 < i2 < ... <iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7 1 7 3 5 9 4 8Sample Output
4
该题就是一道模板题,用来验证算法正确性,下面的AC代码为时间复杂度为O(n2)的dp实现
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
int main()
{
int a[1100];
int dp[1100];
int n;
scanf("%d", &n);
for(int i = 0; i < n; i ++)
{
scanf("%d", &a[i]);
}
dp[0] = 1;
for(int i = 1; i < n; i ++)
{
dp[i] = 1;//这里一定不要用memset进行初始化,该函数只能初始化为0或-1
for(int j = 0; j < i; j ++)
{
if(a[j] < a[i]&&(dp[j] + 1) > dp[i])
dp[i] = dp[j] + 1;
}
}
int ans = dp[0];
for(int i = 1; i < n; i ++)
{
if(dp[i] > ans)
ans = dp[i];
}
printf("%d\n", ans);
return 0;
}
下面的时间复杂度为O(nlogn),该算法是变质了的dp
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
int main()
{
int a[1100];
int d[1100];
int n, len = 1;
scanf("%d", &n);
for(int i = 0; i < n; i ++)
{
scanf("%d", &a[i]);
}
d[1] = a[0];
for(int i = 1; i < n; i ++)
{
if(a[i] > d[len])
{
d[++len] = a[i];
}
else
{
int pos = lower_bound(d, d + len,a[i]) - d;
d[pos] = a[i];
}
}
printf("%d\n", len);
return 0;
}