POJ 2632 - Crashing Robots

Crashing Robots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9882 Accepted: 4218

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
 
Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of 
  • L: turn left 90 degrees, 
  • R: turn right 90 degrees, or 
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

Source

Analysis
模拟题,给一个a*b的矩形,有n个机器人,m个、3种操作:左转、右转、向前走,给出每个机器人的起始位置和方向,若在这m次操作中机器人越界或者碰到另一个机器人,则输出相应信息,若有多次,只输出第一次的信息;若没有,则输出OK。
单纯模拟即可。
Source Code
#include <cstdio>
using namespace std;
struct node
{
    int a,b,c;
} p[128];
int main()
{
    int k,n,m,a,b,num,flag,i,j;
    char s[6];
    scanf("%d",&k);
    while(k--)
    {
        flag=1;
        scanf("%d %d %d %d",&a,&b,&n,&m);
        for (i=1; i<=n; i++)
        {
            scanf("%d %d %s",&p[i].a,&p[i].b,s);
            if (s[0]=='E')
                p[i].c=1;
            else if (s[0]=='N')
                p[i].c=2;
            else if (s[0]=='W')
                p[i].c=3;
            else
                p[i].c=4;
        }
        while(m--)
        {
            scanf("%d %s %d",&i,s,&num);
            if (flag)
                while(num--)
                {
                    if (s[0]=='L')
                        p[i].c=p[i].c%4+1;
                    else if (s[0]=='R')
                    {
                        p[i].c--;
                        if (!p[i].c)
                            p[i].c=4;
                    }
                    else
                    {
                        if (p[i].c==1)
                            p[i].a++;
                        else if (p[i].c==2)
                            p[i].b++;
                        else if (p[i].c==3)
                            p[i].a--;
                        else
                            p[i].b--;
                        if (p[i].a>a||p[i].b>b||!p[i].a||!p[i].b)
                        {
                            printf("Robot %d crashes into the wall\n",i);
                            flag=0;
                        }
                        for (j=1; j<=n; j++)
                            if (i!=j&&p[i].a==p[j].a&&p[i].b==p[j].b)
                            {
                                printf("Robot %d crashes into robot %d\n",i,j);
                                flag=0;
                                break;
                            }
                        if (!flag)
                            break;
                    }
                }
        }
        if (flag)
            printf("OK\n");
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值