POJ 2686 - Y2K Accounting Bug

Y2K Accounting Bug
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13226 Accepted: 6716

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

Source

Analysis
本题大意是有一个公司,丢失了一部分单月的财务报表,但是已知该公司每连续的5个月生成一张总结性的报表,一年中生成的8张报表全都是亏损状态 ,求该公司一年之内最大可能的利润,如果一定亏损,输出 Deficit。
这个题可以用贪心的方法来解,首先设前5个月的盈利月数为5,亏损月数为0,贪心的寻找使这5个月亏损的最大盈利月数n,得出的结果就是每n个月盈利后再有5-n个月亏损,把一年的12个月累加起来即可。
Source Code
#include <cstdio>
using namespace std;
int main()
{
    int a,b,sum,i,ca,cb;
    while(~scanf("%d %d",&a,&b))
    {
        cb=0,ca=5;
        while(a*ca-b*cb>0)
        {
            ca--;
            cb++;
        }
        sum=0;
        for (i=1; i<=12; i++)
        {
            if (i%5&&i%5<=ca)
                sum+=a;
            else
                sum-=b;
        }
        if (sum>0)
            printf("%d\n",sum);
        else
            printf("Deficit\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值