Find The Multiple POJ - 1426

12 篇文章 0 订阅
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

题意

给你一个数n,输出一个数m 要求m只有1 0 组成 m不超过100位

思路

遍历超时,因为每位只能选0 1,所以可以进行bfs ,但涉及大数,要用到同余膜定理

大佬详细思路 https://blog.csdn.net/lyy289065406/article/details/6647917

#include <iostream>
#include <algorithm>
using namespace std;
int mod[10000000]; //存余数,公式(x+y) % n = (x%n + Y%n)%n;
                    //mod[] 就是x%n
int main()
{
    int n,i;
    while(cin>>n)
    {
        if(!n)
            break;
        mod[1] = 1%n; //最高位一定是1;
        for(i=2;mod[i-1]!=0;i++)
        {
            mod[i] = (mod[i/2]*10+i%2)%n; //i/2 i%2 模拟双入口。
        }                                  //可以理解为两种情况,可以对比二叉树理解
                                            // i= 2 i%2=0 相当于第二位选的0
        i--;                               //i=3  i%3=1 相当于第二位选的1
        int pm = 0;
        while(i)
        {
            mod[pm++] = i%2; //把*10操作转化为%2操作,逆向求倍数的每一位数字
            i/=2;           //比如i = 2,4,6,8时我们选的0 i%2=0 即还原我们的选择
        }
        while(pm)
            cout<<mod[--pm];
        cout<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值