Bitset
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 15401 Accepted Submission(s): 11684
Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1 2 3
Sample Output
1 10 11
Author
8600 && xhd
#include<stdio.h>
void exchang(int x)
{
int a[11]={0},n=-1,i;
while(x)
{
n++;
a[n]=x%2;
x=x/2;
}
for(i=n;i>-1;i--)
printf("%d",a[i]);
}
int main()
{
int x;
while(scanf("%d",&x)!=EOF)
{
exchang(x);
printf("\n");
}
return 0;
}