1038 Recover the Smallest Number (30 分)

1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87



结尾无空行

Sample Output:

22932132143287



结尾无空行

Code:

/*
题⽬⼤意:给⼀些字符串,求它们拼接起来构成最⼩数字的⽅式
分析:贪⼼算法。让我们⼀起来⻅证cmp函数的强⼤之处!!~~不是按照字典序排列就可以的,必
须保证两个字符串构成的数字是最⼩的才⾏,所以cmp函数写成return a + b < b + a;的形式,保证它排
列按照能够组成的最⼩数字的形式排列。
因为字符串可能前⾯有0,这些要移除掉(⽤s.erase(s.begin())就可以了~嗯~string如此神奇~~)。
输出拼接后的字符串即可。
注意:如果移出了0之后发现s.length() == 0了,说明这个数是0,那么要特别地输出这个0,否则会什么
都不输出
*/
#include <bits/stdc++.h>
using namespace std;
vector<string> ve;
bool cmp(string a, string b)
{
    return a + b < b + a;
}
int main()
{
    int n;
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        string temp;
        cin >> temp;
        ve.push_back(temp);
    }
    sort(ve.begin(), ve.end(), cmp);
    string s;
    for (int i = 0; i < ve.size(); i++)
    {
        s += ve[i];
    }
    while (s[0] == '0')
        s.erase(s.begin());
    if (s.length() == 0)
        cout << 0;
    else
        cout << s;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追寻远方的人

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值