HDU 1060 Leftmost Digit .

27 篇文章 0 订阅
15 篇文章 0 订阅

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5483    Accepted Submission(s): 2080

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

 

Output
For each test case, you should output the leftmost digit of N^N.
 

 

Sample Input
 
 
2 3 4
 

 

Sample Output
 
 
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

 

Author
Ignatius.L
 
第一次睇到呢个题目,以为系高精度求幂,然后取第一位…………摆左好耐都无做过,琴日见到华神 http://972169909-qq-com.iteye.com/提到
可以利用科学计数法黎做。
众所周知,科学计数法其实就系一个数n = delta * 10^k
题目可以转化为:n^n = delta * 10^k
 
注意到delta个位数部分其实就系最左面既数字,所以我地只要得到delta就咩都搞掂晒啦。
 
所以集合科学计数法后面为10的幂次呢个特点,我地作如下神变:
 
n^n = delta * 10^k
log(n^n) = log(delta * 10^k)
n * log(n) = log(delta) + k
k = floor(n * log(n))
log(delta) = n * log(n) - k = n * log(n) - floor(n * log(n));
delta = 10^(n * log(n) - floor(n * log(n)))
 
求出delta之后,直接int或者floor取整就ok,log(n^n)之所以化成n*log(n)系因为精度问题,n^n会点大家心照啦{= =+}。
k为10既整数幂次,所以显然k = floor(n * log(n)),呢度一定要用floor而唔系int强制转换因为会出错,至于点解会出错,
原因好简单,就系强制double转换int时候既精度缺失{= =},依个系由浮点数储存机制造成,原理可以参考百*百科或者
伪基百科,呢度懒得9up{= =+}。
 
下面献上代码:
42223312011-07-20 10:22:04Accepted10600MS272K493 BC++10SGetEternal{(。)(。)}!
#include <cmath>
#include <iostream>
using namespace std;

int main()
{
 int    T;
 double n;

 scanf("%d", &T);
 while (T--)
 {
  scanf("%lf", &n);

#if 0
  printf("test = %lf\n", n * log10(n) - floor(n * log10(n)));
#endif

  //n = n / pow(10, log10(n));
  printf("%d\n", (int)pow(10.0, n * log10(n) - floor(n * log10(n))));
 }
 return 0;
}

/*
n^n = delta * 10^k
log(n^n) = n * log(n) = log(delta) + k
log(delta) = n * log(n) - k = n * log(n) - floor(n * log(n));
*/
 
多谢收睇{= =*}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值