L2-012. 关于堆的判断

L2-012. 关于堆的判断

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • “x is the root”:x是根结点;
  • “x and y are siblings”:x和y是兄弟结点;
  • “x is the parent of y”:x是y的父结点;
  • “x is a child of y”:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(<= 1000)和M(<= 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出“T”,否则输出“F”。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T

考点:二叉堆

 

二叉堆的实现。还是有必要自己实现二叉堆的插入,删除,建立基本操作的吧?

STLmake_heap函数。这道题这么简单还想着STL帮忙,是不是有点懒?

 

给出两种代码:

#include<bits/stdc++.h>

using namespace std;
const int maxn=1111;

int h[maxn];
int sz=0;
map<int,int>mp;//记录数据在堆中的序号
void Insert(int x)
{
    int i=++sz;
    for(; x<h[i/2]; i/=2)
    {
        h[i]=h[i/2];
        mp[h[i/2]]=i;
    }

    h[i]=x;
    mp[x]=i;
}


int main()
{
    h[0]=-111111111;
    int n,m;
    cin>>n>>m;

    int x;
    while(n--)
    {
        cin>>x;
        Insert(x);
    }

    while(m--)
    {
        int a,b;
        cin>>a;
        string s;
        cin>>s;
        if(s[0]=='a')//兄弟关系
        {
            cin>>b;
            getline(cin,s);
            if(mp[a] == mp[b])
                puts("F");
            else if(mp[a]/2 == mp[b]/2)
                puts("T");
            else puts("F");
        }
        else
        {
            cin>>s;
            if(s[0]=='a')//子父关系
            {
                cin>>s>>s;
                cin>>b;
                if(mp[a]==mp[b])
                    puts("F");
                else if(mp[a]/2==mp[b])
                    puts("T");
                else puts("F");
            }
            else
            {
                cin>>s;
                if(s[0]=='r')//根
                {
                    if(mp[a]==1)
                        puts("T");
                    else puts("F");
                }
                else//父子关系
                {
                    cin>>s;
                    cin>>b;
                    if(mp[a]==mp[b])
                        puts("F");
                    else if(mp[a]==mp[b]/2)
                        puts("T");
                    else puts("F");
                }
            }
        }

    }
}



#include<bits/stdc++.h>

using namespace std;
vector<int>a;
int dis(int x)
{
    return distance(a.begin(),find(a.begin(),a.end(),x));
}
int main()
{

    int n,m;
    cin>>n>>m;

    while(n--)
    {
        int x;cin>>x;
        a.push_back(x);
        make_heap(a.begin(),a.end(),greater<int>());
    }

    while(m--)
    {
        int a,b;
        cin>>a;
        string s;
        cin>>s;
        if(s[0]=='a')//兄弟关系
        {
            cin>>b;
            getline(cin,s);
            int pa=dis(a);
            int pb=dis(b);
            pa++,pb++;
            if(pa/2 == pb/2)
                puts("T");
            else puts("F");
        }
        else
        {
            cin>>s;
            if(s[0]=='a')//子父关系
            {
                cin>>s>>s;
                cin>>b;
                int pa=dis(a);
                int pb=dis(b);
                pa++,pb++;
                if(pa/2 == pb)
                    puts("T");
                else puts("F");
            }
            else
            {
                cin>>s;
                if(s[0]=='r')//根
                {   int pa=dis(a);

                    if(pa==0)
                        puts("T");
                    else puts("F");
                }
                else//父子关系
                {
                    cin>>s;
                    cin>>b;
                    int pa=dis(a);
                    int pb=dis(b);
                    pa++,pb++;
                    if(pa==pb/2)
                        puts("T");
                    else puts("F");
                }
            }
        }

    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值