L2-006 树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

#include<bits/stdc++.h>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;
const int maxn = 50;
int n;
typedef struct node
{
    int data;
    node * lef;
    node * rig;
}node,*tree;
void build_tree(int *las,int *mid,int cnt,tree &tre)
{
    if(cnt == 0)
    {
        tre = NULL;
        return;
    }
    tre = new node;
    tre->data = las[cnt - 1];
    int i;
    for(i = 0;mid[i]!=las[cnt - 1];i++);
    build_tree(las,mid,i,tre->lef);
    build_tree(las+i,mid+i+1,cnt-i-1,tre->rig);
}
void bfs(tree &tre)
{
//    printf("hello\n");
    queue<tree> q;
    q.push(tre);
    int cnt = 0;
    while(!q.empty())
    {
        tree now = q.front(); q.pop();
        if(now)
        {
            if(cnt) printf(" ");
            cnt++;
            printf("%d",now->data);
            if(now->lef) q.push(now->lef);
            if(now->rig) q.push(now->rig);
        }
    }
}
int main()
{
    int mid[maxn];
    int las[maxn];
    scanf("%d",&n);
    tree tre = NULL;
    for(int i = 0;i < n;i++) scanf("%d",&las[i]);
    for(int i = 0;i < n;i++) scanf("%d",&mid[i]);
    build_tree(las,mid,n,tre);
    bfs(tre);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值