hust——1010F - The Minimum Length(kmp专练)



F - The Minimum Length
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%lld & %llu

HUST 1010





Description


 There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.     




Input


 Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.     



Output


 For each line, output an integer, as described above.    


Sample Input


bcabcab
efgabcdefgabcde



Sample Output


3

7


题意是输出循环节的长度   

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int nexta[1000010];
void getnext(string s)
{
	int i=0,j=-1;
	nexta[0]=-1;
	while(i<s.size())
	{
		if(j==-1||s[i]==s[j])
		{
			++i;
			++j;
			nexta[i]=j;
		}
		else j=nexta[j];
	}
}
int main()
{
	string s;
	long long n,k;
	while(cin>>s)
	{
		getnext(s);
		k=s.size();
		n=k-nexta[k];//循环节
		cout<<n<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值