UVA 409 Excuses, Excuses!

Excuses, Excuses! 

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.
Input
Input to your program will consist of multiple sets of data.
Line 1 of each set will contain exactly two integers. The first number ( tex2html_wrap_inline30 ) defines the number of keywords to be used in the search. The second number ( tex2html_wrap_inline32 ) defines the number of excuses in the set to be searched.
Lines 2 through K+1 each contain exactly one keyword.
Lines K+2 through K+1+E each contain exactly one excuse.
All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L ( tex2html_wrap_inline42 ) and will occupy columns 1 through L in the input line.
All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.
Excuses will contain at least 1 non-space character.
Output
For each input set, you are to print the worst excuse(s) from the list.
The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.
For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.
After each set of output, you should print a blank line.
Sample Input
5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?
Sample Output
Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?


Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!

yiyi:给出N个关键词,M 个句子。打印含有关键词最多的句子,如果句子中的词为大写,转换成小写时与关键词相同的话也考虑进去。

#include <stdio.h>
#include <string.h>
char kw[21][21], jk[21][110];
int match (char word[],int a) {
	for (int i = 0; i < a; i++) {
		if (strcmp(kw[i], word) == 0)
			return 1;	
	}
	 return 0;
}
int main () {
	int f, s,i, j, term, max, case1 = 1;
	int count[21];
	char word[21];
	while (scanf("%d %d" , &f, &s) != EOF) {
		max = -1;
		getchar();
		memset(count, 0, sizeof(count));
		//输入关键词
		for ( i = 0; i < f; i++) {
			gets(kw[i]);
		}
		//输入借口
		for ( i = 0; i < s; i++) {
			gets(jk[i]);
			int len = strlen(jk[i]); 
			for (j = 0; j < len; ) {
				//分离单词和大写换小写
				term = 0;
				while ((jk[i][j] >= 'a' && jk[i][j] <= 'z') || (jk[i][j] <= 'Z' && jk[i][j] >= 'A')) {
					if (jk[i][j] <= 'Z' && jk[i][j] >= 'A') {
						word[term++] = jk[i][j] - 'A' + 'a';
					}
					else {
						word[term++] = jk[i][j];
					}	
					j++;	
				}
				j++;
				word[term] = '\0';
				//匹配
				if (match(word, f))
					count[i]++;

			}
			if (max < count[i])
				max = count[i];
		}
		printf("Excuse Set #%d\n", case1);
		case1++;
		for (i = 0; i < s; i++) {
			if(max == count[i])
				puts(jk[i]);
		}
		printf("\n");
	}
		return 0;
}

回复回复

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是一个简单的学生请假管理系统的代码示例,使用Python语言编写,采用了基本的面向对象编程思想: ```python class Student: def __init__(self, name, id): self.name = name self.id = id self.absences = 0 self.excuses = [] def add_excuse(self, excuse): self.excuses.append(excuse) def get_excuses(self): return self.excuses def add_absence(self): self.absences += 1 def get_absences(self): return self.absences class AttendanceSystem: def __init__(self): self.students = [] def add_student(self, student): self.students.append(student) def get_student(self, id): for student in self.students: if student.id == id: return student return None def mark_absence(self, id): student = self.get_student(id) if student: student.add_absence() def add_excuse(self, id, excuse): student = self.get_student(id) if student: student.add_excuse(excuse) def get_student_report(self, id): student = self.get_student(id) if student: report = "Student Name: {}\nStudent ID: {}\nAbsences: {}\nExcuses: {}\n".format(student.name, student.id, student.absences, student.get_excuses()) return report return None ``` 以上代码定义了两个类:`Student`和`AttendanceSystem`。`Student`类代表一个学生,包含了学生的姓名、学号、缺勤次数和请假记录;`AttendanceSystem`类代表整个请假管理系统,包含了所有学生的信息和管理操作。 使用这个代码示例,你可以创建学生对象并添加到请假管理系统中,记录学生的缺勤次数和请假记录,以及查询某个学生的请假报告。你可以根据自己的需求进行修改和扩展。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值