01-复杂度2 Maximum Subsequence Sum (25分)(数据结构)(C语言实现)

Given a sequence of K integers { N​1 , N2​​ , …, N​K
​​ }. A continuous subsequence is defined to be { N​i , N​i+1​​ , …, N​j
​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

想必大家应该已经了解如何求最大子列和的问题,但是现在我们改变一下,不仅要求出最大子列和,还要求出最大子列和是从数组下标什么时候开始,什么时候结束的。
这个问题可能对于小白来说可能有点困扰。
我们的思路肯定是在当恰好到最大子列和的第一个数开始计算数组下标的,然后到最后一个数又恰好停止。

我们可以这样想:
引入两个变量来计算下标。
我们来看一下代码:

#include<stdio.h>
#define N 10000
int main()
{
    int i,x;
    int c,d;
    int a[N];
    scanf("%d",&x);
    for(i=0;i<x;i++)
    {
        scanf("%d",&a[i]);
    }
    MaxSubseqSum(a,x);
    return 0;
}
int MaxSubseqSum(int a[],int x)
{
    int i;
    int first,last;
    int maxsum=-1,thissum=0;
    int one=0;
    for(i=0;i<x;i++)
    {
        thissum+=a[i];
        if(thissum>maxsum)
        {
            maxsum=thissum;
            first=a[one];
            last=a[i];

        }
        else if(thissum<0)
        {
            thissum=0;
            one=i+1;

        }

    }
    if(maxsum==-1) printf("0 %d %d\n",a[0],a[x-1]);
    else printf("%d %d %d\n",maxsum,first,last);

    
}

maxsum为什么首先要设置为-1,因为你输入的数中很有可能是0,所以0如果只有0,那么0就是最大值.
首先,当ThisNum>MaxNum的时候,我们就第一次计数,first就是0,然后last就是当前的i。然后当ThisNum<0的时候,我们就需要重新计数了,first就是当前的i+1了。所以这道题目也不是很难的,需要大家想一想!

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值