【PAT甲级】1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

代码

版本一:

错因:举个例子,当一个多项式中出现10*X3,当读取到这个项式的时候,会把指数3加入到名为con的set容器中,一个多项式中出现了-10 *X3,这时候两个多项式相加,指数为3处的系数是为0的,但在con中并没有将其删除。

所以改动方法即,当v[e]=0时,删除con中对应的那个e

#include<iostream>
#include<vector>
#include<cstdio>
#include<unordered_set>
using namespace std;
int main(){
    vector<double> v(1001,0);//哈希表,下标为代表指数,数组代表对应系数
    unordered_set<int> con;//用来记录有几项非零系数的指数
    for(int i = 0; i < 2; i++){
        int k;
        cin >> k;
        while(k--){
            int e;
            double c;
            cin >> e >> c;
            v[e] += c;
            con.insert(e);
            //第一版错误点,没有考虑到系数相加为0的情况
            if(v[e]==0) con.erase(e);//当相加后系数重新变为0,也要在con中将e删去
        }
    }
    cout << con.size();
    for(int i = 1000; i >= 0; i--){
        if(v[i]!=0){
            printf(" %d %.1f",i,v[i]);//输出格式空格放在前面就不需要那么麻烦

        } 
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值