HDU 6325 Interstellar Travel(转角法)

Problem G. Interstellar Travel

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1473    Accepted Submission(s): 357


 

Problem Description

After trying hard for many years, Little Q has finally received an astronaut license. To celebrate the fact, he intends to buy himself a spaceship and make an interstellar travel.
Little Q knows the position of n planets in space, labeled by 1 to n. To his surprise, these planets are all coplanar. So to simplify, Little Q put these n planets on a plane coordinate system, and calculated the coordinate of each planet (xi,yi).
Little Q plans to start his journey at the 1-th planet, and end at the n-th planet. When he is at the i-th planet, he can next fly to the j-th planet only if xi<xj, which will cost his spaceship xi×yj−xj×yi units of energy. Note that this cost can be negative, it means the flight will supply his spaceship.
Please write a program to help Little Q find the best route with minimum total cost.

 

 

Input

The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.
In each test case, there is an integer n(2≤n≤200000) in the first line, denoting the number of planets.
For the next n lines, each line contains 2 integers xi,yi(0≤xi,yi≤109), denoting the coordinate of the i-th planet. Note that different planets may have the same coordinate because they are too close to each other. It is guaranteed that y1=yn=0,0=x1<x2,x3,...,xn−1<xn.

 

Output

For each test case, print a single line containing several distinct integers p1,p2,...,pm(1≤pi≤n), denoting the route you chosen is p1→p2→...→pm−1→pm. Obviously p1 should be 1 and pm should be n. You should choose the route with minimum total cost. If there are multiple best routes, please choose the one with the smallest lexicographically.
A sequence of integers a is lexicographically smaller than a sequence of b if there exists such index j that ai=bi for all i<j, but aj<bj.

 

Sample Input

1

3

0 0

3 0

4 0

 

Sample Output

1 2 3

 

Source

2018 Multi-University Training Contest 3

Recommend

chendu   |   We have carefully selected several similar problems for you:  6343 6342 6341 6340 6339 

 

【思路】

整条路径的叉积和最小意味着绝对值最大,因此也就相当于找一个以x轴为下边界的凸包,同时要求点序的字典序最小,我们便要在凸包上选合适的点,拐角之间的共线点找一串序号严格单增的即可,因此直接扫一遍用转角法搞一下上凸包即可。注意重合点与共线情况的判定。

 

【代码】

//******************************************************************************
// File Name: G.cpp
// Author: Shili_Xu
// E-Mail: shili_xu@qq.com
// Created Time: 2018年08月02日 星期四 22时21分14秒
//******************************************************************************

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
using namespace std;
typedef long long ll;

struct point {
	long long x, y;
	int id;

	point(long long _x = 0, long long _y = 0, int _id = 0) : x(_x), y(_y), id(_id) {}
	
	bool operator<(const point &another) const
	{
		if (x == another.x && y == another.y) return id < another.id;
		return (x < another.x) || (x == another.x && y < another.y);
	}
};

typedef point vec;

vec operator-(point a, point b)
{
	return vec(a.x - b.x, a.y - b.y);
}

long long det(vec a, vec b)
{
	return a.x * b.y - a.y * b.x;
}

int t, n;
vector<point> p, ans;

int main()
{
	scanf("%d", &t);
	while (t--) {
		p.clear(); ans.clear();
		scanf("%d", &n);
		for (int i = 1; i <= n; i++) {
			long long x, y;
			scanf("%lld %lld", &x, &y);
			p.push_back(point(x, y, i));
		}
		sort(p.begin(), p.end());
		ans.push_back(p[0]); ans.push_back(p[1]);
		for (int i = 2; i < p.size(); i++) {
			if (ans.back().x == p[i].x && ans.back().y == p[i].y) continue;
			while (ans.size() >= 2 && (det(ans.back() - ans[ans.size() - 2], p[i] - ans[ans.size() - 2]) > 0
			|| (det(ans.back() - ans[ans.size() - 2], p[i] - ans[ans.size() - 2]) == 0 && p[i].id < ans.back().id))) ans.pop_back();
			ans.push_back(p[i]);
		}
		for (int i = 0; i < ans.size(); i++)
			printf("%d%c", ans[i].id, " \n"[i == (int)ans.size() - 1]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
How should we use data to help us analyse our beliefs? This book is concerned with the subjectivist analysis of uncertainty, and develops methods that combine prior judgements with information derived from relevant data. Whenever we move from broadly data-focused questions, such as ‘Does this data set suggest that a certain medical treatment is likely to be effective?’, to broadly decision-motivated questions, such as ‘Are we sufficiently confident, given all that we know about this treatment, to recommend its widespread use?’, then we must make such a synthesis of data with more generalized forms of information. Because we may find this hard to achieve, we need some methodology to help us. This methodology should be clear, helpful, logically well founded and tractable. The Bayesian approach to statistics is the natural methodology for this purpose. This approach treats all uncertainties within a common probabilistic framework, combining the different sources of information using the rules of probability. This approach has a sound logical foundation and a well-developed methodology and is popular and successful in many areas of application. However, in large-scale applications, the Bayesian approach can easily become the victim of its own ambition. Representing all uncertainties in probabilistic form is a daunting task for complicated problems. This is partly because of the intrinsic difficulties in judging the value of each relevant source of knowledge. However, in large part, the task is difficult because the Bayesian approach requires us to specify our uncertainties to an extreme level of detail. In practice, it is usually beyond our ability to make meaningful specifications for our joint probability distributions for multiple outcomes. If we do wish to follow a broadly Bayesian path, then we must either choose to make specifications that do not correspond to our actual uncertainties or be more modest about our ability to render our beliefs in probabilistic form. If the data are plentiful and unambiguous in their message or if the problem is not sufficiently important to merit careful analysis, then little harm is done by somewhat misrepresenting our beliefs. However, when the issue is important and data are less plentiful, then we must be more careful and honest. When we cannot make full belief specifications, we require alternative methods that respect the limitations on our abilities to specify meaningful beliefs and allow us to conduct partial analyses strictly in terms of the actual limited aspects of our beliefs that we are able to specify.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值