hdu 5615 (Jam's math problem)

 数学  Jam's math problem

Description

Jam has a math problem. He just learned factorization. 
He is trying to factorize $ax^2+bx+c$ into the form of $pqx^2+(qk+mp)x+km=(px+k)(qx+m)$. 
He could only solve the problem in which p,q,m,k are positive numbers. 
Please help him determine whether the expression could be factorized with p,q,m,k being postive.

Input

The first line is a number $T$, means there are $T(1 \leq T \leq 100 )$ cases 

Each case has one line,the line has $3$ numbers $a,b,c (1 \leq a,b,c \leq 100000000)$

Output

You should output the "YES" or "NO".

Sample Input

2
1 6 5
1 6 4

Sample Output

YES
NO


        
  

题意:ax^2+bx+c能否转化成十字相乘的形式((pm+kq=b))

题解:若能转化,则x必为有理数,求根公式 x=(-b±√△)/2a,判断 △是否为完全平方数。

 

<span style="font-size:18px;">#include<cstdio>
#include<cmath>
using namespace std;

int main(){
	int t;
	long long a,b,c;
	scanf ("%d",&t);
	while (t--){
		scanf ("%lld %lld %lld",&a,&b,&c);
		long long m=b*b-4*a*c;
		long long k=sqrt(m);
		if (k*k==m)
		printf ("YES\n");
		else
		printf ("NO\n");
	}
	return 0;
} </span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值