05-树9 Huffman Codes (30分)

05-树9 Huffman Codes (30分)

In 1953, David A. Huffman published his paper “A Method for the Construction of Minimum-Redundancy Codes”, and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string “aaaxuaxz”, we can observe that the frequencies of the characters ‘a’, ‘x’, ‘u’ and ‘z’ are 4, 2, 1 and 1, respectively. We may either encode the symbols as {‘a’=0, ‘x’=10, ‘u’=110, ‘z’=111}, or in another way as {‘a’=1, ‘x’=01, ‘u’=001, ‘z’=000}, both compress the string into 14 bits. Another set of code can be given as {‘a’=0, ‘x’=11, ‘u’=100, ‘z’=101}, but {‘a’=0, ‘x’=01, ‘u’=011, ‘z’=001} is NOT correct since “aaaxuaxz” and “aazuaxax” can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤63), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] … c[N] f[N]
where c[i] is a character chosen from {‘0’ - ‘9’, ‘a’ - ‘z’, ‘A’ - ‘Z’, ‘_’}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (≤1000), then followed by M student submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]
where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0’s and '1’s.

Output Specification:

For each test case, print in each line either “Yes” if the student’s submission is correct, or “No” if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

Sample Output:

Yes
Yes
No
No

#include<bits/stdc++.h>
using namespace std;
int Check(string ss[],int N);
int main(){
	map<char,int>m;
	priority_queue<int, vector<int>,greater<int> >q;
	int N,V,num,val,len;
	char c;
	cin>>N;
	for(int i=0;i<N;i++){
		cin>>c>>num;
		m[c]=num;
		q.push(num);
	}
	while(1){
		num=q.top();q.pop();
		if(q.empty())break;
		num+=q.top();q.pop();
		q.push(num);
		val+=num;
	}
	cin>>V;
	for(int i=0;i<V;i++){
		len=0;
		char t;
		string ss[N];
		for(int i=0;i<N;i++){
			cin>>t>>ss[i];
			int l=ss[i].size();
			len+=l*m[t];
		}
		if(len!=val||!Check(ss,N))printf("No\n");
		else printf("Yes\n");
	}
}
int Check(string ss[],int N){
	sort(ss,ss+N);
	for(int i=0;i<N-1;i++)
		for(int j=i+1;j<N;j++)
			if(ss[j].find(ss[i])==0)return 0;
	return 1;
}
#include<bits/stdc++.h>
using namespace std;

typedef struct TNode* Ptr;
struct TNode {
	char c;
	int f;
};

int N, Size;
Ptr Heap[100];
map<char, int> codeMap;

void Insert();
Ptr Delete();
void Pre(int root);

int main() {
	cin >> N;
	
	char c;
	int fre, sum = 0;
	Size  = 0;
	
	for (int i = 1; i<= N; i++) {
		cin >> c >> fre;
		codeMap[c] = fre;
		getchar();
		Heap[i] = (Ptr)malloc(sizeof(struct TNode));
		Heap[i]->c = c;
		Heap[i]->f = fre;
		Size++;
		Insert();
	}
	
	for (int i = 1; i < N; i++) {
		Ptr root1 = Delete();
		Ptr root2 = Delete();
		root1->f += root2->f;
		sum += root1->f;
		Heap[++Size] = root1;
		free(root2);
	}
	
	int number;
	cin>>number;
	while (number--) {
		char C1;
		map<string, bool> fuck;
		string code[N], s1, s2;
		int judge = 0, flag = 0;
		for (int i = 0; i < N; i++) {
			cin >> C1 >> code[i];
			if (flag == 1) continue;
			if (fuck[code[i]] == true) flag = 1;
			fuck[code[i]] = true;
			getchar();
			judge += (codeMap[C1] * code[i].length());
		}
		
		for (int i = 0; i < N; i++) {
			code[i] = code[i].substr(0, code[i].length()-1);
			if (fuck[code[i]] == true) flag = 1;
		}
		
		if (judge == sum && !flag) printf("Yes\n");
		else printf("No\n");
	}
}

void Insert() {
	Ptr Temp = Heap[Size];
	int X = Heap[Size]->f, i = Size;
	for (; i > 1 && Heap[i / 2]->f > X; i /= 2)
		Heap[i] = Heap[i / 2];
	Heap[i] = Temp; 
}

Ptr Delete() {
	if (!Heap[1]) return nullptr;
	
	Ptr Temp = Heap[1];
	
	Heap[1] = Heap[Size--];
	
	Pre(1);
	
	return Temp; 
}

void Pre(int root) {
	Ptr Temp = Heap[root];
	int X = Heap[root]->f, Parent = root, Child;
	
	for (; Parent * 2 <= Size; Parent = Child) {
		Child = Parent * 2;
		if (Child != Size && Heap[Child]->f > Heap[Child + 1]->f)
			Child++;
		if (X <= Heap[Child]->f)
			break;
		else Heap[Parent] = Heap[Child]; 
	}
	Heap[Parent] = Temp;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值