PAT(甲级)2019年春季考试7-3 Telefraud Detection (25 分)

43 篇文章 0 订阅
5 篇文章 0 订阅

7-3 Telefraud Detection (25 分)

Telefraud(电信诈骗) remains a common and persistent problem in our society. In some cases, unsuspecting victims lose their entire life savings. To stop this crime, you are supposed to write a program to detect those suspects from a huge amount of phone call records.

A person must be detected as a suspect if he/she makes more than K short phone calls to different people everyday, but no more than 20% of these people would call back. And more, if two suspects are calling each other, we say they might belong to the same gang. A makes a short phone call to B means that the total duration of the calls from A to B is no more than 5 minutes.

Input Specification:

Each input file contains one test case. For each case, the first line gives 3 positive integers K (≤500, the threshold(阈值) of the amount of short phone calls), N (≤10​3​​ , the number of different phone numbers), and M (≤10​5​​ , the number of phone call records). Then M lines of one day’s records are given, each in the format:

caller receiver duration
where caller and receiver are numbered from 1 to N, and duration is no more than 1440 minutes in a day.

Output Specification:

Print in each line all the detected suspects in a gang, in ascending order of their numbers. The gangs are printed in ascending order of their first members. The numbers in a line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

If no one is detected, output None instead.

Sample Input 1:

5 15 31
1 4 2
1 5 2
1 5 4
1 7 5
1 8 3
1 9 1
1 6 5
1 15 2
1 15 5
3 2 2
3 5 15
3 13 1
3 12 1
3 14 1
3 10 2
3 11 5
5 2 1
5 3 10
5 1 1
5 7 2
5 6 1
5 13 4
5 15 1
11 10 5
12 14 1
6 1 1
6 9 2
6 10 5
6 11 2
6 12 1
6 13 1

Sample Output 1:

3 5
6
Note: In sample 1, although 1 had 9 records, but there were 7 distinct receivers, among which 5 and 15 both had conversations lasted more than 5 minutes in total. Hence 1 had made 5 short phone calls and didn’t exceed the threshold 5, and therefore is not a suspect.

Sample Input 2:

5 7 8
1 2 1
1 3 1
1 4 1
1 5 1
1 6 1
1 7 1
2 1 1
3 1 1

Sample Output 2:

None
主要注重题目细节,short phone算的是总的通话时间, > K 并且 <=5 并且 <=0.2,只有short phone的对象回电才算call back, 只有两个suspects 互相都打过电话才算是一个gang的,最后并查集number小的节点作为根节点, 细节还是很多的容易出错。

#include<bits/stdc++.h>
using namespace std;
int N, M, K, e[2005][2005] = {0}, father[2005];
unordered_set<int> v[2005];
vector<int> suspect, ans[2005];
int find(int n) {
	if (father[n] != n) return father[n] = find(father[n]);
	else return n;
}
void Union(int a, int b) {
	int fa = find(a);
	int fb = find(b);
	if (fa != fb) {
		int t = min(fa, fb);
		father[fa] = t;
		father[fb] = t;
	}
}
int main() {
	scanf("%d %d %d", &K, &N, &M);
	int a, b, c;
	for (int i = 0; i < 1005; i++) {
		father[i] = i;
	}
	for (int i = 0; i < M; i++) {
		scanf("%d %d %d", &a, &b, &c);
		e[a][b] += c;
		v[a].insert(b);
	}
	for (int i = 1; i <= N; i++) {
		int cnt = 0, recall = 0;
		for (int j : v[i]) {
			if (e[i][j] <= 5) {
				cnt++;
				if (e[j][i] > 0) recall++;
			}
		}
		if (cnt > K && (recall * 1.0 / v[i].size() <=  0.20)) suspect.push_back(i);
	}
	if (suspect.size() == 0) {
		printf("None\n");
		return 0;
	}
	for (int i = 0; i < suspect.size(); i++) {
		for (int j = i + 1; j < suspect.size(); j++) {
			if (e[suspect[i]][suspect[j]] > 0 && e[suspect[j]][suspect[i]] > 0){
				Union(suspect[i], suspect[j]);
			}
		}
	}
	set<int> st;
	for (int i = 0; i < suspect.size(); i++) {
		int fa = find(suspect[i]);
		st.insert(fa);
		ans[fa].push_back(suspect[i]);
	}
	for (int i : st) {
		sort(ans[i].begin(), ans[i].end());
		for (int j = 0; j < ans[i].size(); j++) {
			if (j != 0) printf(" ");
			printf("%d", ans[i][j]);
		}
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值